Low pool earnings and lots of "Error in pooling: 'Partial was received too late"

Hi everyone,
i’m member of a pool and have 118plots. now, after an update some days ago, i’m getting much less earnings. the shown difficulty in the pool overview shown only 1, but was 3 before. “Points Successful in Last 24 Hours” says 1.27%. And the pool-site show an estimated size of 131.847GiB (should be around 12TiB).
the farmer is running on a RasPi 4B inside a docker. since the update it shows me lots of messages like this:

2023-06-01T18:03:53.407 farmer chia.farmer.farmer : ERROR Error in pooling: (2, 'Partial was received too late. Received in 226.10231614112854. Make sure your proof of space lookups are fast, and network connectivity is good. Response must happen in less than 25 seconds. NAS or network farming can be an issue')

i tried to reinit chia (excluding db) multiple times but the error persists.

Any help appreciated

1 Like

This means your partials are not arriving at the pool on time (they’re stale)


Maybe something happened, causing your drive to sleep?


i didn’t asked what that means, but how to fix this error

power management is turned off, so there should be no standby

Just looked up the logs and thought these lines might be helpful:

chia_farmer: started
2023-05-27T11:53:49.916 full_node chia.full_node.full_node: WARNING Block validation time: 2.93 seconds, pre_validation time: 0.56 seconds, cost: 2289581010, percent full: 20.814% header_hash: cbf3df0ec8fb4cf9fa23fcf1fce6a0d1c99fe4e0a4aa122daa6f09f72b01dc75 height: 3719889
2023-05-31T20:27:36.796 full_node chia.full_node.full_node: WARNING Block pre-validation time: 10.09 seconds (32 blocks, start height: 3720204)
2023-05-31T22:18:03.249 full_node chia.full_node.full_node: WARNING Block validation time: 2.67 seconds, pre_validation time: 0.76 seconds, cost: 5340101996, percent full: 48.546% header_hash: 59f59ad622936a677e60649030f4e9f192473bf8cce718daa43223d6adc17b1d height: 3740279

10mins after that last entry the mentioned error in pooling occurs the first time

I thought you needed help… anyway

That’s not how this works

so then… where is this helpful?
where is ur solution or even a way to get deeper into analysis?

1 Like

Solo farm for a few days and see if you get the same error. Your pool might have had issues or their internet.

Compressed plots?

FlexFarmer probably would work a lot better on Pi, the Pi isn’t really good enough for the node which is why Evergreen uses FF for theirs. You can get it to work but it won’t be the best.

1 Like

so, switched some hours to solo farming

the warning persists, but way less messages. up to now no error about “partial was received too late”

2023-06-02T18:57:36.250 full_node chia.full_node.full_node: WARNING Block validation time: 5.83 seconds, pre_validation time: 1.01 seconds, cost: 5133319128, percent full: 46.667% header_hash: 12cb9fd2001669a9000bdc7ba56ed9c9d4b144d234e16865db020d58d76bf708 height: 3748927

since those plots are now around one year old, no compressed plots

For such a small farm you should really consider flexpool’s flexfarmer (or spacepool equivalent)

You should also consider the lowest compressed plots, they are better.

so ur telling me, that those plots and the pool which are working since around a year are suddenly not working because of the existence of those compressed plots?

1 Like

Oh no, there is definitely an issue, just switching to FF solves it easier than trying to diagnose it lol.

thought this is a support forum
the idea of a support forum is gernerally to diagnose things and solve them

ur answers are like to the problem “hey my usb isn’t detected”, no prob: “switch to linux”


1 Like

This is not a paid service. You should not expect spot-on solutions to a problem.

You are not the first one to have their problem go unresolved. I , too, have asked questions that went unresolved. I did not complain to anyone that offered advice, even when their advice did not resolve my issue – and some advice was out of left field, and some advice would have caused more problems.

It was up to me to accept and reject advice, without jumping on anyone.

Yes, it is frustrating to have an issue go unresolved. But it is no one else’s fault. It could be that no one here has a solution for you.

I offered what I think might be your issue:

You dismissed it:

I waited to see if someone else, or you, would find a solution.
But now that you are getting uppity about it, I will point out that your dismissal of your drive powering down is possibly in error.

You did not perform a test to confirm, matter of factly, that your drive’s platters are not powering down. You are relying on a setting, and not on confirmation of that setting’s reliability.

To know, without a doubt, that your drive is not sleeping, you need to run a test to confirm that it is not sleeping. You need to confirm that your drive’s platters have not gone to sleep.

Shut down Chia. Wait for 30+ minutes, to give your drive a chance to sleep (even though you believe it will not sleep).

Then start a large file copy (like a plot), and see if the copy starts on the first second, or if it waits a few seconds for the drive to spin up. If the room is quiet, and you are close to the drive, you will hear it spin up.

I suggested a large file copy (like a plot), to eliminate that the file is in your RAM cache. You want to be sure that your file copy must read from the drive’s platters.

I suggested that you shut down Chia for this test, because you do not want anything running that will access the drive you are testing. You want to confirm that when nothing is accessing the drive, that it does not sleep.

Late Chia challenge responses are typically due to your hard drive not reading plot info on time. That points to your drive sleeping, regardless of your settings.


If you go to this site https://xchscan.com/ and look at the transaction history for 14 days. Those high days are going to stress the pi’s cpu and chia db.

I use command line tools like top and iotop to have a first look at what is happening and dmesg -T to look for disk problems

Is your setup on an external ssd or a sd that may be starting to wear out? If you have a spare, dd it on and see if helps

I can’t make any help with docker as I didn’t ever run chia that way

This is WAY longer than a disk spin up, is your system unresponsive at this time? Check in /var/log for errors around the same time

Exactly why I stopped responding

1 Like

lol…good luck finding help with an attitude like that