MAdMax how to run completely in RAM?

Hi There!

First post :grin: I am new to Chia, have been building rigs and trying to get them to run the last 2 weeks. I run a bussiness in refurbished server hardware in the netherlands and while bussiness is slow i was trying out different systems to play around with.

Currently i have 3x R720 12x 3.5" - 2x E5-2695v2, 192GB DDR3 1333Mhz, H310 mini, 1x Samsung PM1725b 6.4TB HHHL. Drives i run atm are 12x 12TB Seagate Exos, i have 40x 10TB WD(so 12x in use) and one system running on 24x 1.8TB 2.5" SAS 12G drives.

So im running Ubuntu 20.04 on all three and i tried swar plotting manager and managed to get it to run at 24 plots per day per server. But with 400+TB to fill it would simply take too long. So i have just tried MAdMax’s plotter and it really is a different beast altogether. I have managed to run a single plot in 1739.9Sec so 29min. which is awesome! Now im able to run 48 plots each or total 144plots/15TB per day on those 3 systems.

So the next build i wanted to try out is as followed:
1x HPE ProLiant DL380 G10 - 2x Xeon Gold 6130 (2x 16Core/32Threads), 512GB PC4-2666Mhz RAM, and no NVME.

I would like to run the entire plotting in memory. How can i change the MadMax plotter to completely run in RAM ? Any tips? i have some experience with linux but im by no means a expert in it.

Would love some feedback!

  • Max
-t, --tmpdir arg     Temporary directory, needs ~220 GiB (default = $PWD)
-2, --tmpdir2 arg    Temporary directory 2, needs ~110 GiB [RAM] (default = <tmpdir>)

use a ramdisk for both temp1 and temp2

RAM disk setup on Linux

sudo mount -t tmpfs -o size=110G tmpfs /mnt/ram/


Sorry maybe i should have been clearer. I have all 3 systems running now with -t = NVME and -2 = RAM disk @ 160GiB

How do i run completely in “-2” it now shares load 25 to 75% right? or can i just not enter a temp dir for -t ?

The code is setup so that it can utilize two temp drives, and yes the work is split 25% temp1 and 75% temp2

If you leave out the temp2 argument, then temp2 defaults to temp1; i.e. they can be the same disk…
make temp1 your ram disk and leave temp2 argument out.

Most setups will have temp1 NVMe and temp2 RAM

1 Like

Hi Max,

Oke great thanks! Just the info i needed! System is build and ready, just installing chia etc


Hi Max,

I ran into errors all day today. Do you know what could be the cause of:

Blockquote Wrote plot header with 268 bytes
Terminate called after trowing an instance of ‘std::runtime_error’
what(): thread failed with: fopen() failed
Aborted (core dumped)

The system now runs completely in RAMdisk (409GiB)

Any idea?

Sorry, not enough info there.

Best to open up an ‘issue’ at the madmax github repo:

You ever figure this out? Running into the same issue.