Madmax plating consumes 100% of the CPU regardless of my config!

Hi All,
when i set -r 4 or 6 or 8 or 12 , It makes no difference, in any case, it uses 100% of the CPU.
Where do you think the problem is?
I do not have a good heatsink and the CPU temperature always goes above 90!

Mb : asus prime b250 plus, core i7 7700k , nvme 970 pro 1tb, ram 24g 2400 .

I think its kinda setup that way. It seems it just uses all.
I have noticed both better times and no crashes when i stepped down from 24 to 22 threads (out of total24)

Maybe it only sets a priority leaving the system free to use the other threads. But when they are idle it still uses them for plotting

Edit i’d spend the 20-30$ and get a better cooler

1 Like

Your i7-7700k has only 8 threads, so this is expected.

The r setting is actually for “pairs” of threads, and there’s also helper threads in addition. If you’re running linux, you can see this by running top and press “H” to show threads.

For example, running -r 20 right now, I have 20 “phase1/eval” threads, 20 “phase1/match” threads, and 5 “Disk/read” threads, and a few others like phase1/slice etc. There’s a total of over 70 threads from running -r 20.

If you want to use less than 100% cpu, you need to choose a lower number than -r 4.

1 Like