MadMax Plotter: Simple workaround for Windows (running plotter in Ubuntu subsystem)

If you have the same problem as me to get Mad Max plotter working in Windows, this might be a temp solution. Works great so far.

  1. install ubuntu (18.04) app from windows store:
  2. from windows administrator PowerShell prompt run “Enable-WindowsOptionalFeature -Online -FeatureName Microsoft-Windows-Subsystem-Linux”
  3. open ubuntu app, create user and login
  4. run “sudo apt-get update”
  5. update manually to latest cmake version: How to upgrade cmake in Ubuntu - Ask Ubuntu
  6. install mad max plotter, follow ubuntu instructions from here: GitHub - madMAx43v3r/chia-plotter
  7. in ubuntu verify that windows ntfs drives where auto mounted, run “ls /mnt”
  8. in windows, open admin cmd and enter chia deamon dir, run “chia keys show”, take note of public pool & farmer key
  9. in ubuntu enter max max plotter build dir and run plotter like this: sudo ./chia_plot -n 1 -r 32 -u 128 -t /mnt/d/ -2 /mnt/d/ -d /mnt/d/plots/ -p “yourpoolkeyhere” -f “yourfarmkeyhere”

Why all the manual steps in step 5? Why not just “sudo apt install cmake”?

because it wont fetch the latest version required

Worked fine for me. But that was after I failed at making the manual steps work.

Failed to write to tmpdir directory: ‘/mnt/E/’ when i try to run the command

But does it worth to try ? Last time i checked the windows version is a lot slower than the linux one, and they still utilize 100% cpu / hdd

Linux is case sensitive. I doubt that the drive is “/mnt/E” it is most likely “/mnt/e”.

Using this method you are running the linux one.

More on WSL2 here What is Windows Subsystem for Linux | Microsoft Docs

I also recommend the windows terminal too so you have unix and windows sessions side by side

Doesnt the windows terminal(ubuntu 20.4) have performance issues with writing to drives outside of the VHD? And would this hit make it slower than just using windows?

Anyone know if the 18.04 suffers from this?

Since there is no official windows version of MadMax, I wouldn’t go that route. I don’t see any significant slow down in writing to the drives.

And for anyone doing these instructions. You don’t need to manually install cmake. I have confirmed that “sudo apt install cmake” works fine. I have done it on two more systems and no problems.

Thanks for the reply.

Is it slower than an actual install of Ubuntu OR a VM?

Also can you raid the drives and use btrfs via this method?


any reason for 18.04 instead of 20.04?

Nope, I’m running 20.04.2.

I literally just got it up and running on 20.04. I see some commands do not work like lsblk so does that mean you cannot mkfs or mdadm? Was hoping to take advantage of linux discard/trim options with btrfs file system?


That is probably the fact that it doesn’t have control of the drives since it is running as a subsystem of Windows. I have rtrim running as a scheduled task in windows.

Yea I run raid which windows trim does not seem to be supported…

Looks like if you go WSL2 you get access to control disks with linux:

I have some all in one computers that I am using usb NVME drives on.

I used the windows version of Madmax(fury road) on a couple of them…

I have 1 set up with this setup now and ran 1 plot and the result was Fury road 8108s and Ubuntu 20.04 8973s.

I just set up Ubuntu 20.04 on another machine that was using Fury Road but this time I did the WSL2 setup. I will post my results but if the first few table times are any clue, they are worse…


EDIT: I stopped the WSL2 it was TERRIBLE. All the table times were 4X as long…

Yeah WSL2 is notoriously bad at IO. I would definitely avoid it for plotting. Might work just fine for farming though.

If you want the best perf for plotting, highly recommended to use Linux instead (latest Ubuntu is just fine).