Many Errors after 1.2.0

Hello, after update 1.2.0 I have many errors in debug.log, in config its set to INFO. Here is the list:

2021-07-15T02:06:53.171 harvester harvester_server : ERROR Exception: ‘utf-8’ codec can’t encode characters in position 68-70: surrogates not allowed <class ‘UnicodeEncodeError’>, closing connection {‘host’: ‘’, ‘port’: 8447}. Traceback (most recent call last):
File “/home/chia/chia-blockchain/chia/server/”, line 533, in api_call
response: Optional[Message] = await asyncio.wait_for(wrapped_coroutine(), timeout=timeout)
File “/usr/lib/python3.8/asyncio/”, line 494, in wait_for
return fut.result()
File “/home/chia/chia-blockchain/chia/server/”, line 530, in wrapped_coroutine
raise e
File “/home/chia/chia-blockchain/chia/server/”, line 523, in wrapped_coroutine
result = await coroutine
File “/home/chia/chia-blockchain/chia/harvester/”, line 310, in request_plots
return make_msg(ProtocolMessageTypes.respond_plots, response)
File “/home/chia/chia-blockchain/chia/server/”, line 45, in make_msg
return Message(uint8(msg_type.value), None, bytes(data))
File “/home/chia/chia-blockchain/chia/util/”, line 344, in bytes
File “/home/chia/chia-blockchain/chia/util/”, line 330, in stream
self.stream_one_item(f_type, getattr(self, f_name), f)
File “/home/chia/chia-blockchain/chia/util/”, line 308, in stream_one_item
self.stream_one_item(inner_type, element, f)
File “/home/chia/chia-blockchain/chia/util/”, line 316, in stream_one_item
str_bytes = item.encode(“utf-8”)
UnicodeEncodeError: ‘utf-8’ codec can’t encode characters in position 68-70: surrogates not allowed

2021-07-15T02:06:53.172 farmer farmer_server : INFO Connection closed:, node id: 41485f651884b979f1b26dd890cd9218b31ae39dae458f629cbef6a6f13627ec
2021-07-15T02:06:53.172 harvester harvester_server : WARNING Trying to ban localhost for 10, but will not ban
2021-07-15T02:06:53.172 harvester harvester_server : INFO Connection closed:, node id: ac5ea6899493c06686388af3f7243fd7394a45a4ba8a2bc6c133b47ad89f283c
2021-07-15T02:06:53.172 farmer chia.farmer.farmer : INFO peer disconnected {‘host’: ‘’, ‘port’: 8448}
2021-07-15T02:06:53.172 harvester chia.harvester.harvester: INFO peer disconnected {‘host’: ‘’, ‘port’: 8447}
2021-07-15T02:06:53.173 farmer chia.farmer.farmer : ERROR Harvester did not respond. You might need to update harvester to the latest version

This plus the fact that I cannot see the plots in GUI and not farming correctly is a mess… Currently on 1.2.2 and still the same. Any thought on how can I resolve the errors one by one? Thanks!

PS: I run on Ubuntu 20.4 LTS

There is some special character in something that python has a problem with because the character encoding is set to utf-8

Any chance you are norwegian and have fancy characters in the name of your folders, pc etc.?

1 Like

No, pc is in US english. This is a minor error, the others concen me more: harvester disconnecting, something about banning, cannot see plots in gui and not farming. 1.2.0 is a hell of an update

I have the same issue after I upgraded to 1.2.0 then1.2.2, and when I try any chia command on a terminal, it shows some data and then I get a ¨Segmentation fault (core dumped)" message, also I found that the harvester process is in zombie status.
I’m using Linux Centos

yeah, since 1.2.0 everything is fucked… I can only add 24 plot directory for the farm to work, if I add more plots disappear and wallet is not farming…so other half of my farm is offline…that is also why netspace was the same for the last few weeks, wallets not showing plots and ppl getting fucked.

Do you get the message “Segmentation fault (core dumped)", when you try the chia command on a terminal?

I’m going to try moving some plots to check if that makes any difference to me.

I reduced the number of plots, but I keep getting the same error

My “Segmentation fault (core dumped)" was because Python was no 3.7 or above. :slight_smile: