Missing plots or they are just hidden?

I have 2 machines. Harvester and full nod. I decided to swap the harvester’s hard drives and the four plots I had made were missing. Only the recycle bin icon is visible on the disc, but the plots are missing or not visible. The plots still take up disk space, but are not visible. Added hard in the full nod machine, but still not visible. Anyone with a similar problem? thanks

Can you give everyone a description of systems/OS etc.
More detailed the better usually. Thanks

I solved the problem. I released a check disk and it fixed things.There is a bad sectors, but the plots appeared and are ok. Thanks

Bad sectors. You did not say if you ran chkdsk /r /f specifically. I’d try that. If your issue returns, then reformat the drive (after you move the data somewhere else). If you cannot reformat the drive, depending how full it is and how large it is, it may be time to replace the drive.

chkdsk fix all things. All the plots appeared and I managed to copy them to another hard drive. Only one of the plots did not work. Then I formatted the hard drive. I hope this hard drive doesn’t cause problems in the future.

If you run Windows, check Crystal Disk Info for drive health. It will read out the SMART data (if enabled on system/drive) and tell you what’s wrong and if the drive is dying or not.