My farmer is not receiving any XCH

The last time I received tokens is April 25, 2023 and It’s been 5 months since I’ve gotten anything. My Chia GUI version back then was v1.4. I did not do anything to my plots or changed any setting in Chia. I just suddenly noticed that I stopped receiving anymore XCH. Did something happen in this date?

I then updated to the latest Chia GUI, v2.0 and now fully synced.
Still the same thing. I am not receiving any XCH at all.
I do see some activity though when you go to Full Node > Blocks. I am seeing State “finished” and it is refreshing often.

I have 2 plots. One group is NFT Pooling to spacepool, the other is solo farming. I have made them last year and didn’t touch anything to them, so they should be working as intended but I am not sure why I stopped receiving tokens since last April. Any help? (Detailed guide would be appreciated since I barely fiddle with Chia often).

Edit 2: I tried resyncing my wallet as this old post suggests (via the GUI), didn’t delete my wallet db file.
I then reload my Chia gui as it requires it to do so
Now I am starting to gain points in my Pool in the Pooling tab.
It will take awhile but let’s see if I receive some Chia again.

To resync wallet. Settings > Advanced tab > resync wallet.

Do you have an old config.yaml? rename the config.yaml to config-cya.yaml, then do a chia init which will create the correct config.yaml. Then just add your drives and pool info in. You could use notpad++ to compare the two files and see whats different. Also install chia 2.0.1 for the current base.

What’s my other option if I don’t have my old config.yaml file?

I checked space pool. I am starting to get points. Waiting for an hour or so if Chia will start coming in.

Having backup files are always good to have. for the amount of little space they take, it could save you hours.
A lot of changes have been made since 1.4

Last try I will make before I hit a brick wall.
I DID note my old xch_target_address in config.yaml. I read somewhere that whenever you update the Chia GUI, it gets randomly changed for some wierd reason.

I’ve also copy pasted the last address in tokens tab and pasted it in my Pooling payout address.

I just updated it right now and I’ll come back here for a status update in about 30 mins to an hour to see if I start getting chia again.

Sometimes you can go for months very dry…

I noticed something strange though.
In my directory I have
and inside this folder, I have another mainnet folder which has

Is this the current folder structure now in Chia 2.0? Or did I mistakenly duplicated the chia mainnet folder onto here?

This is what I have on one machine running 2.0.1
Also when you shut down the chia GUI, I copy these two directories to a USB backup disk for CYA. Then you have a backup of the whole deal.

1 Like

I think I’ll copy first the config.yaml in that mainnet folder within my mainnet folder and then delete that mainnet folder within my mainnet folder.

How do I do chia init? (Sorry if this is a very beginner level question). I’ve never used Chia CLI at all yet.
I’m wondering if I can do that with my current situation if it will work. I’m going to rename my current config.yaml to config-cya.yaml and then do chia init.

Shut down chia then go and rename the config.yaml to config-cya.yaml
Go to
C:\Program Files\Chia\resources\app.asar.unpacked\daemon
Then run chia init
It will make a new config.yaml file, the just add your plot drive directories.

1 Like

Ok I will try your suggestion in an hour or so.
I did notice that my unpaid chia is increasing, but if I still don’t get any chia, I will execute this suggestion. Usually I’d start to receive chia when it gets to around 0.012-0.019 XCH of unpaid chia or so.

Do you also take note of your original xch_target_address in your old config.yaml file?
They say that you have to take note of it due to some bug

If the newly generated config.yaml doesn’t have the same xch_target_address, I’ll be sure to replace it. I still do have mines and changed it in my config.yaml file when I first updated my GUI to v2.0

you must run 1.8 or higher otherwise its just a big dry run you have over there

second of all. LOT of people complained they got bad luck since may this year, soo … welcome to the club.

you must run 1.8 or higher

Do you mean version 1.8 higher of the GUI client? Would like to see the anecdotal evidence/source

second of all. LOT of people complained they got bad luck since may this year

Afaik, pool farming should give you guaranteed rewards, not luck dependent. I’m doing pool farming on this one.

There is none, I got it clarified a while back when I noticed a lot of farmers are running old versions on the pool I’m on, it was very clearly stated they will still find blocks, for now.

We had some forks where updating the gui was recomen
ded if you still wanted to forge blocks

I’ve gotten it to work without needing to rebuild my config.yaml file. It seems that resyncing the wallet did it and also setting the payout address to the last known working address in your transactions history list (in my case, the xch censored address in the picture).

So to anyone not receiving chia, try this:
Try resyncing your wallet (either via the gui) or deleting the wallet db file. I did mines via the gui in advanced tab > resync wallet

Go to your pool’s website and copy/paste your launcher ID from Chia GUI Pooling tab > Your Pool in their search bar to check if you’re actually farming points and that the pool is actually receiving your input. If it is, then all you need to do is wait for the payout to occur. Mines occurs daily as seen in the screenshot, if it reaches a certain amount.

Try to set your payout address to the last known working one in transaction history. Go to pool > click on your NFT Pool (3 Dots) > Edit Payout Instructions > copy the last working address from Tokens tab and paste it in there.

Also make sure you noted your original xch_target_address value from config.yaml. You have to note your original (yes, since day 1 of farming) address since the moment you started farming. This is because this value gets changed whenever you update the Chia GUI and it can cause you not to receive XCH farm rewards. You have to make sure that the address value is set to that original, day 1 address. That’s the most annoying yet crucial nuance with Chia which I managed to did note :slight_smile:

Also make a backup of the files as drhicom says.
But I wouldn’t necessarily backup the big db folder (.chia/mainnet/db). That can be safely rebuilt from scratch from a fresh install, especially if you don’t have enough space in your usb or drive. Only config.yaml and in config folder and the wallet folder have significance from what I’ve read.

Thank you everyone as well

If you don’t back up the whole thing yes you can recover, it just takes a lot of time. (CYA-backup the whole pouch for me). Also install on another machine a let sync once a month for another backup…

1 Like