Need help on paralle plotting using Mad max plotter on Windows

Hello Everyone,

I am plotting on Windows using Mad Max plotter and my current time to create a new plot is 26 minutes using 20 threads and plotting in RAM as secondary temp storage. Below is my current configuration:
CPU: AMD Ryzen™ Threadripper™ 3960X Processor - 24 Core
RAM: 144 GB
NVME: I have three 1 TB NVME’s. Currently, I am using only one as the first temp location with RAM.

I tried running another Mad max plotter parallelly using the other two NVME’ with the below config:
Threads 20
Buckets 256
Two 1 TB NVME’s
When I run the second Mad max plotter, the system takes around 80 mins to finish one plot. Also, my first plotter takes a hit of additional 10 mins to finish one plot in 35 mins.

Can anyone suggest to me how can I run two mad max plotters parallelly to create plots faster?

Any suggestions guys??? ANy settings that can be changed in mad max plotter?

Try using -r 16 for each process. I’ve found the best performance to be at -r = physical cores count + a little with my dual xeon v3 system, up until the new -K argument was added. Now I use -r = physical cores -K 2 to get the best time for single plots. I would also try running an individual run on your RAM with -r 32 (that’s what I used with my 24 core system prior to -K for best time).

1 Like

Thank you for the feedback

1 Like


I have the same configuration. For the Windows version (v0.1.1)), I don’t see yet the new -K argument. What is the purpose of it?

The -K flag was added to the main project github and has not been ported to stotiks’ windows build yet. The purpose is to double the -r value during phase 2. Most people were seeing the best performance by using slightly more than their physical core count for -r, which was a delicate balance between performance gain from phase 2 and performance loss from phase 3. With -K, you can set -r to physical cores for maximum phase 3 performance, while also gaining maximum phase 2 performance from doubling the multiplier.


Thanks a lot for the explanation @gryan315

1 Like

i am kinda new with the mad max plotter, hope you can help me. I have 5900x with 12 cores and 24 threads, 64gb ram and 3 SSD Nvme, the one on D: is 2TB, other on E: is 1TB and the third on F: is also 1TB

What do you suggest my options are for the best performance? How do i put them all to work :smiley:

I would first test them one at a time. Use -r 16 -u 256 -t nvme -c p2 address -f farmer key This will create the file and leave it on the NVMe drive for you to move to another directory afterward. Once you’ve found the fastest NVMe, you can possibly get a little extra performance by using one of the other 2 as -t, and the fastest drive as -2. I would also experiment with -u 128, and possibly -u 256 -v 128. This would leave you with a final command something like -r 16 -u 256 -t nvme -2 fastest nvme -d destination -c p2 address -f farmer key You should also test with a few -r values of 12 to 20, but I suspect 16 or 18 will be the fastest.

You may need to sleep for 1000 seconds to wait the phase 1 of first job finish.

I am getting the best results with -r 24 -u 256 -v 128 and two NVME’s or one NVME and RAM.

1 Like

Thank you guys, it really helped me until today :smiley: I created plots in about 34 minutes, but last night i noticed that the MadMax is killing my SSD-s quicker then it should. I used SWAR for creating plots for hpool and core pool, and i have around 140TB of those, my SSDs are on 70,80 percent of health. After i engaged MadMax week ago and created around 24TB of NFT plots, they are on 49percent of health right now. It is eating my SSDs. Do you have some solution for this? They are WD BLACK SN850 NVMe 1TB
Am i doing something wrong? Temperatures are around 40-50 celsius, i have vents cooling them…

One solution would be a use a Ramdisk for tempdir2, it’ll take 75% of the writes. The manual says you need 110GB of ram for this, some people have tried less with mixed results.

If you have an enterprise-level system or threadripper/epyc system with 256GB of ram you could try doing the entire plotting process in ram. Unfortunately most consumer motherboard/procressors only support up to 128GB of ram. :upside_down_face: