No incoming peers despite open 8444 open

I’ve been struggling with this problem ever since. I had ds-lite from my internet provider which basically means that I was sharing one IPv4 address with many customers and therefore I had no chance to forward port 8444 to my full node. So I talked to the provider and switched the contract. Now I do have a designated IPv4 address. Upnp is working correctly and several port scanners tell me that 8444 is open.
Yet I never have incoming peers, it’s always saying 8444/8444 which means the connection was initiated by my node. Most of the time I’m connected to something like 5 peers and once a day I completely loose sync. Why is that?

I’ve configured a dyndns service. Please try to connect to my node under
Does it work for you? Are you able to connect to that node?

hello @sardelle, welcome to the forums :slight_smile:

you can test your ports here Open Port Check Tool - Test Port Forwarding on Your Router

also you can add this to your peers

Use these nodes if you are having trouble connecting to the introducers: North America:, Europe:, Asia:

1 Like

My guess is that 8444 may be open on the system but not forwarded properly in your firewall/router. Use the link vavi posted to check because you need to check from outside your network, not just a port scanner within your network. When I forwarded 8444 on my firewall, within an hour I had over 60 peers.

I’m connected!!
good idea to get around a NAT with ddns. I have also been strugeling with no access to the router and upnp disabled

actually now I realize, if u are behind a nat, other nodes are going to try to connect at your router’s adres not the ddns, but other can connect if they manualy enter your ddns, a vpn could be a better solution

I used exactly this site to check my port 8444 and is says it’s open.
18650nerd was apparently able to connect to my node using which simply is a dns pointing to my WAN IPv4. All of that means that my router is configured correctly. Yet I don’t see incoming peer connections.
I even tried to fully disable the firewall in my router and on my OS but that did not help.

1 h later connection to your node was gone, does your provider rotate IPs often? this would disconnect all the nodes

I can fix it and guarantee a permanent connection, but there is a charge

Port 8444 being shown as open does not necessarily mean the traffic is getting to your chia full node system. It could be getting sent somewhere else. Or your firewall could have upnp turned on and it is answering on the port itself. The bottom line is that the upnp traffic is not making it to the system you are wanting peers on.

I think you will be way better if you remove dynamic dns. It adds so many variables on too many layers. For example other nodes will resolve you only one time and not do any further resolution attempts. I cannot go to any technical details because I do not know in detail how chia distributed network works, but ddns while perfect for hosting your own website on your home pc, is not perfect for distributed networks like chia.

I’ve been having the same problem with initial sync, with Chia 1.1.6, a Windows 10 PC and an Asus RT-AC66U router. UPnP is enabled on the router but I’ve tried it enabled and disabled in the config.yaml file. The port forwarding is set correctly on the router, and my ISP has assured me that I’m not behind a carrier-grade NAT. Multiple port checkers indicate 8444 is open on my node (not just the router). My node has a static IP address. Windows Defender is off, and I’ve given permission for every Chia process I could identify in my Bitdefender firewall. Also tried syncing (briefly) with Bitdefender off.

Nevertheless, I haven’t seen a single peer connection, even when letting the sync run for over 48 hours.

I suspect the problem is the router, similar to what @WolfGT described above. This router is old and is known to have port forwarding issues. I uploaded Merlin firmware to the router with no improvement.

Planning to replace the router this weekend, but are there any other suggestions? Am I missing something obvious?