No read write permission on HDD - Linux desktop

Hey Ya’ll,

In the interest of using old unused hardware for Chia I have 2 WD HDD. 1 TB and 3 TB that I want to plug into my rig and use for farming.

Both HDDs had some data and 2 partitions each. I deleted the partitions from the “Disks” tool in Linux desktop GUI. I formatted and mounted the HDDs using terminal and following commands:

sudo mkfs.ext4 -m 0 -T largefile4 -L <drivename> /dev/sda
mkdir /mnt/hdd
mount /dev/sda /mnt/hdd

Issue I have is that I am not able to paste/move/ write any data on these empty HDDs. I am not able to create any folder either. Here are screenshots of the drives itself:

Please let me know if you need any other data or information to help. Any suggestions? How can I make this a writable HDD? I followed the same steps with my other WD Gold drives and they seem to be working fine.

What is the permission for /mnt/hdd?

I am not a pro at these commands, and not sure what you mean. But I wrote “Sudo” in front of each command. Does that help?

sudo chmod 777 /mnt/hdd
will give everyone full permission to /mnt/hdd

1 Like

Thanks @snef, I tried but still getting this error while creating a new folder:


Do I need to reboot?

Check out this link for instructions on how to mount a drive on Linux:

1 Like

you need to

sudo chmod 777 /media/apoorv/HDD1TB

I thought you mounted it under /mnt/hdd

1 Like

No reboot necessary.

sudo chmod 777 /mnt/hdd

will only work for the root folder. In order to apply it for all subfolders you must add -R parameter. Linux is almost always case sensitive, so -R is not the same as -r. Also it is better to stick to 4-digits with chmod. In some cases 0777 means not the same as 777. So try:

sudo chmod -R 0777 /mnt/hdd

Then: if you want to plot under linux and later move to windows I would suggest to make the drives in NTFS format. You can perfectly write that in linux and then later easily migrate to windows. NTFS can be read by windows, linux, mac and raspberry pi :slight_smile:

1 Like

Thanks @snef appreciate you going the extra mile to help. Clearly I am a noob, but hey, I learned a new thing thanks to you. It seems to be working now.


Keep in mind that if you automount a drive in fstab and the drive is missing linux won’t boot. Even if the missing drive is just a data drive and not the system drive.

I have created a bunch of mount points in fstab all with the noauto parameter. Upon boot I just go to the disks utility in ubuntu and mount them one by one using the “play buttons”. I know its not ideal and perfect, but for now it works for me (after I had some non-boots due to drives I disconnected).

1 Like

Thanks @chiachiachia I already have 2 full 10 TB drives in Ext4. Too late for them I guess, unless I can move the plots from Ext4 drive to a new NTFS one, in that case will try to do that. For the new ones, I think I will stick with NTFS as I want to keep my options open when I turn this rig from Plotting/ farming to gaming/ farming setup.

Probably even for the temp drives it doesn’t matter, but for those I like to stick to ext4 as you never know. It might be a bit more faster and there is no benefit in using NTFS for the temp drives. :slight_smile:

1 Like

Yeah, as long as I am plotting, I will stick with Linux. So I don’t see why I would need to go the NTFS route just yet.