Not able to sync: debug.log: "Cannot connect to host"

after a pc crash I’m not able to sync anymore…
I have the latest 1.2.9 version
here is the error message from log:

2021-10-19T01:29:00.587 farmer farmer_server : INFO Cannot connect to host ssl:<ssl.SSLContext object at 0x000001DF43650840> [The remote computer refused the network connection]
2021-10-19T01:29:02.029 wallet wallet : INFO Reconnecting to peer {‘host’: ‘’, ‘port’: 8444}

here is a screen shot of the full node:

the wallet shows total balance and show not synced:

here is a screenshot of the farm showing last height farmed (it is strange since I remember seeing a higher height over 1’000’000):

what makes me think it’s not syncing in background is that the last edit to the database is a few minutes before the pc crash :

I see the same error allover the internet but it’s not clear how to solve it.
Can someone please help?

I’ve re installed like 8 x in the last 72 hrs…
Machine issue, not chia issue.

First thing I try is deleting all files in the database folder except the biggest one, the blockchain database.

Many ppl offer a longer fix for this, but I find that alone is enough sometimes.

So I’d try

1… stop chia
2. Delete aforementioned files.
3. Restart chia.

I’m not going anywhere, if that doesn’t help, I’ll show steps for the next slightly longer possible fix.

thank you, appreciate your fast reply
still waiting for the gui but same errors in the log files at the moment
edit: please don’t tell me to delete the database… it will take forever… :slight_smile:

OK, if that errors still showing I’d wait a bit, might catch up.

While we wait, another error you might encounter on this journey,.

When selecting your keys, wallet doesn’t load, and you need to select keys again, don’t bother just click the little eye to show your pvt keys on the key itself, wallet loads instantly then.

I’d like to give credit to who sussed this but alas I’m drunk, and can’t recall who it was.

Sorry for long reply, phone died.

Any joy yet, or are we ready for next attempt?

no luck until now…

same errors

OK, while we wait, is chia on a hdd, or ssd?

it’s on an ssd (still good according to crystaldiskinfo)

1 Like

Yh, that’s fooked i think.

I doubt this works, but I’m trying to save you having to resync whole chain.

  1. Stop chia
  2. Move that big file somewhere safe.
  3. Delete all files on that folder as before including big one.
  4. Start chia.
  5. At select keys window stop chia.
  6. Replace your hopefully good database ( big file) with corresponding file in folder.
  7. Start chia and pray.
1 Like

If that doesn’t work, your big d/b file prob got corrupted and needs to sync from scratch.

Always try to keep a copy somewhere once ur synced.
But you must stop chia before making the backup copy.

1 Like

well, no luck… have to sync form scratch (FU%^&^*&)
maybe I forgot to pray…
thanks for the help anyway! :slight_smile:

No worries, glad to help.
As I said, always try to keep a backup copy once ur synced up.
Even if it’s only when you shut down for installing newest release.
A few weeks sync is much better than months.

I think I’ll actually offer a free solution for this as best I can.
Chia official won’t approve it, but I can’t see why a trusted ( over time) torrent wouldn’t be used.

It’s odd, bram being our leader , there no torrent available, strange world we live in.

1 Like

yeah, I always forget once things run smoothly…
lesson learned (for the 3th time)

it would be nice if developers could find a way to sync faster…
I’ll lose 3-4 days of farming (FU*%#)

1 Like

“It’s odd, bram being our leader , there no torrent available, strange world we live in.”

Chia Network is decentralized, peer to peer, pretty much the basic idea behind bittorrent, i think.
In this case however all data (the blockchain) is automatically and continuously updated between all nodes, instead of a user just getting the files he wants to and then sharing just those files to other users (nodes) in the network.
If there was an high bandwidth download source for the blockchain and many users would prefer a quick download from that source, that would be a very attractive target for hackers (or worse the owner of the source) to manipulate the blockchain… bye bye defi!

That said, synchonizing 30GB plus nowadays is no fun;-(

Sorry, forgot to add that Bones suggestion of making you’re own backup copy of the db directory is a very good idea.
Just don’t forget to stop all Chia processes accessing the database first or you might end up with a corrupted and unsuable backup.

1 Like

This address is your PC. It looks to me as if port 8444 is closed somewhere in your local network.

1 Like

I had that constantly for a while.
My ports were forwarded and open.
It was due to corruption in chia software somehow.
But no point jumping straight to re install before checking these simpler possibilities, which sometimes fix it.

1 Like

I forgot to mention that the ports are openned and frowarded (I turn off the firewall to check)

mybe the updated database could be validated by a blockchain type process

Yep, for those having the same issue here is a little summary:
Root cause:

  • This happened to me 2-3 times and on all of them I had an issue with the PC while Chia was running
  • It is due, most probably, to a corrupted db file

How to fix:

  • Mybe I’m unlucky but whatever I tried to quick fix didn’t work…
  • So deteling the db files and restarting Chia is the solution

How to avoid in the future (or avoid waiting a few days to sync):

  • Make a backup of your db folder (DO NOT FORGET TO STOP CHIA BEFORE)
  • It’s prefereable to lose 5 min once in a while (every month?) than 3 days to fully sync…
1 Like

I just envision chia official torrent updated weekly.

Surely can’t be that hard to implement.

1 Like

BTW, do not plot while syncing… just in case someone forgets about it (like I did, for 24h…)
It’s more than 4 times faster to sync if not plotting on the same machine

1 Like