Old GUI version loading 1.3.1 after update from source to 1.6.2

I am on Ubuntu 20.04. I was on 1.3.2 Chia Blockchain GUI version, then I tried to update from source to 1.6.2 through the terminal according to github instructions.

I get a message that 1.6.2 is installed, and the new Chia Blockchain GUI opens ok after the “bash start-gui.sh” command, but the terminal is stuck at the "Executing command in 1 package: “npm run start” " phase.

When I close the terminal, the GUI closes, and when I reopen the Chia Blockchain app from the shortcut icon, version 1.3.1 loads.

I tried deleting the package-lock.json in the chia-blockchain gui folder and running “install.sh” again like the github instructions say, but I get the same exact problem.

Should I delete the Chia Blockchain application completely and start over? I tried looking for the application in the “Ubuntu Software” program under the “installed” tab, but I could not find the application in order to remove it.

I also tried these commands I found on reddit, and all it did was make me re-sync with the blockchain, but the problem is still not fixed–I am still stuck on version 1.3.1:

cd ~/chia-blockchain

. ./activate

chia stop -d all



rm -rf ~/chia-blockchain

rm -rf ~/.chia

rm -rf ~/.chia_keys

Does anyone know how to completely remove the Chia Blockchain application?

First if you were at 1.3.1 your data base was very old, don’t even know if you could even do a db upgrade from that old version to 1.6.2. Hope you have your key info, 24 word phrase. if you have a backup of that disk maybe. I would delete it all and reinstall the latest add the 24 word phrase gen my keys and let it sync for a day or so depending on your ISP speed etc. Good luck.

1 Like

Thanks for your reply. So how do I even delete the old version? I looked in the “ubuntu software” program and the chia blockchain application is not even listed. I even tried deleting all the old “chia blockchain gui” and “chia blockchain” folders, but the application is still there on my desktop, and when I open it, it is version 1.3.1.

How much do you have on that box. Would have to google for that info.