Please check your logs for "ERROR Could not find authentication sk for pk"

We have discovered the source and a partial solution for this ERROR. If you have this error you have a big problem and should read up to message 39 in this thread. Message 80 contains my partial solution to this problem. Be well! :smiley:

Please make sure your log info is on and check your logs for

ERROR Could not find authentication sk for pk

If you are having this error it will probably be almost constant and impossible to miss.

If you have the error you will need to perform chia plotnft show and chia wallet show to find out how bad your problem is.

I know through my research that others have this error and would like to know how wide spread it is.

Thanks in advance! :sunglasses:

p.s. I am chatting with the devs about these errors on keybase but so far have gotten no closer to eliminating the pk sk error or explaining the Wallet type 9 error. keybase support eventually led me to the problem but not a solution

Which software version are you running?

I am on v1.2.6 running on Win, and don’t see that error in my logs.

In one way it means that the company that provides the software and took ~$70m investment is lame enough, so their main UI are engineering logs, where majority of casual farmers are married to their phones, and really have hard time to understand what log means, not to mention engineering entries.

1 Like

I am getting responses on keybase in the Chia Team support chat but nobody seems to have any answers beyond suggesting I perform a chia plots check for reports of missing keys.

I did a Chia plots check n-30. It does not report any missing keys. Two bad plots identified but other than that, no warnings or errors.

“farmer chia.farmer.farmer : ERROR Could not find authentication sk for pk:” today makes up about half of the entries in my log file.

So all my plots check as good with no missing keys but I am still receiving the error.
Other log entries indicate that I am finding plots eligible for farming when the error does not occur. There are no other regular errors except the occasional harvester error which might be related to the pk sk error.

I disconnected all Chia plot directories and exited and re-started chia.exe. I added just my first driectory of OG K32s. the farmer chia.farmer.farmer : ERROR Could not find authentication sk for pk: is still constant but I do see some plots found eligible.
I repeated procedure and used one OG K33 plot directory with exact same result.
Third repeat with NFT K33s still had constant error but now I see no plots found eligible at all.

I provided all of the information above including the Wallet type 9 error in the keybase chat. So far, silence …

I would like to think the devs could give me some answers but so far they do not seem able to do so.

1 Like

When you do plots check just to check the keys, you can use -n 1 (will still use 5) to speed up the process.

In order to have that be your plots related, you would need to have new plots coming, as only those are the new element. Also, we can assume that there was some corruption here and there, but your plots check excluded that option.

So, either your farmer is corrupted, or is getting some garbage from the network. As you are getting those errors when you when you connected your OG plots, that excludes some bad pool request.

So, the best bet is really your chia version that doesn’t really responds well to chia network requests, or Chia Network “enhanced” some requests, and you are the first that is monitoring those logs.

So, I would push harder devs, as I doubt that this has anything to do with your plots.

1 Like

Yeah, I did the -n 30 just to be thorough for the devs.

I agree with your assessment that it is not my plots, but a corrupted farmer or other like issue.

Conversation still going with devs. They are trying, lol!

1 Like

That is always a problem when you hire high schoolers to do coding, and let them be creative with error messages that no one goes over. “As long as it is not on the network side, we can let the end-users test it” attitude.

When you move those errors to UI, you really need to understand what are those issues. Otherwise, it is just “who cares, it should never happen.”

1 Like

Again, you just need to have one test to check those keys. All additional check are just rehashing the first one, but with different challenges, so completely irrelevant. If they were asking for 30, than you were chatting with a wrong guy.

No, -n 30 was my initiative, lol. I wanted to do the deep check anyways and knew I had two plots that were bad but sometimes seemed to be there. The deep check seemed the best way to make sure I found them and to solidly confirm that my plots were good…

Joke on me is that after the long run I identified the two bad plots and then later closed powershell without noting the filenames, lolz! When I run plots check tomorrow to find the bad plots again I will use -n 1!

1 Like

By the way, which Chia version are you running?

I wiped Chia from my PC and installed 1.2.7 clean as soon as it was released. I knew this would make me have to re-sync, but was hoping the clean procedure would fix my error. It did not.

Nah, unless someone believes in magical power of 30, that number is just drawn from a hat. When you run two checks, you are not “better” checking your plots, as both checks need to run over that plot in exactly the same way. When you run -n 30, is just to distract you with some voodoo logic that plot may be good/bad from replying to network requests. When you run the same plots with -n 60, you may get some bias in another direction. So, anything above 1 is more or less useless.

Ad I mentioned, I have v1.2.6, and don’t see those errors. It is possible, that some messages were enhanced, and v1.2.6 is ignoring that extra part (so I don’t see those). Or rather that they are running some A/B tests with some new features, and you ended up in the shitty group.

I have been having these errors since I installed the first Chia client that was pool ready and could plot NFTs. Multiple client upgrades have not changed a thing except that the error has become more common.

At first the error was rare but now it takes up most of my log.

While you are chatting with them, maybe you could ask them to put some “Errors FAQ” that would list the most common errors, and what are the best steps to fix those, or which can be ignored.

I have some errors in my logs, but those are just purge engineering garbage (e.g., Error in pooling: (1, ‘Requested signage point was reverted’)).

My take is that this is just dumb to have all of us separately ask for the same errors, and waste each other time, where they do basically shit to smooth the process.


So, maybe this is somehow related to the pool you belong to? Maybe you could reach out to that pool as well. Maybe they modified the pool code, and introduced this issue. I had one issue like that.

I have never joined any pool.

Just ran chia plotnft show and chia wallet show at dev request. I have 54 wallets! Wallet number one is “Standard Wallet”. The rest of the wallets are "Pooling Wallet"s. It looks as if every time I did an NFT parallel plot Chia created a new wallet for just those three plots (occasionally two as I filled end of HDD). They have not yet responded to my question if this is normal, lol.

That really sucks. Although, as only 2-3 plots belong to such mini-wallet, your “Estimated Time to Win” is like thousand years, but still possible to be lucky, though. Maybe you could just start consolidating those mini-pools, and dump those extra wallets. Or, I assume you use just one cold wallet on all those mini-pools.

Thankfully, I don’t have those problems. All my plots are K32, though, and all are MadMax generated (on few computers). Maybe that is a K33 or latest OG “feature?”

Sometimes, I am thinking that Chia Network signed a deal with energy providers, and are creative to have us replot from time to time for no reason, where they get some kickbacks. Of course, not true, but all the pain is on our side.

Yep. We have confirmed the problem.

I always used the Plot page to create plots. When NFTs came out I continued to do so. I did not want to join a pool so never hit the Join a Pool button on the Pool Page. I should have done this for my first NFT plot and then done the next step which I was unaware of to create my own pool. After that I should have always used the Pool page to create further NFTs, all in the same self-pool I first created.

By using the plot page I ended up creating a new pool and a new wallet every time I plotted. The Chia GUI limit for wallets is 20 and that is not recommended. I have 54 wallets.

Now after .bak and re-creating my config.yaml it does not create/include the required Pool_List heading or the wallet entries under it. I have broken my client by creating too many wallets.

Since updating config.yaml farmr tells me that I am not farming or harvesting at all and my log is almost all errors.

Wallets cannot be deleted and at this point, neither can the references to the wallets be removed from the Chia GUI. The dev I was chatting with said he hoped that there would be a way to do so soon.

At this point it appears that due to my lack of knowledge and a GUI that offers no explanations have led to my entire farm being useless.

Dev has suggest a possible re-plot out of the problem but not a too many wallet fix.

I think the only way I can have a Chia farm after this colossal screw up is to format the machine and all the plotting drives, install Chia and start from scratch with a new mnemonic. Over 70TiB of plots and plotting utterly wasted.

I think its time for bed. Today has been a complete bummer.

Thats some really bad news, sorry for your loss.
One thing to consider before replotting is to make sure you get it right.

This statement seems incorrect to my mind , so tread carefully.

Firstly, if you create an nft and don’t point it at a pool it’s automatically self pooling, so no need to create your own pool, it just does it as self pooling unless you then point that nft at a pool.

Secondly, creating further nft’s all in the same self pool you created seems wrong.
Each nft can self pool or pool depending on what you want.
There would be no point creating further nft unless you want to split your plots, so one nft self pooling, another at pool xyz.

I have OG plots and 1 nft that I plot to, as I won’t split my farming I have no need for more than one nft.

1 Like

Really sorry to hear that.

I would suggest to switch to MadMax, as that is an independent plotter, so will force you to provide correct data, and at the same time will not be able to screw up your Chia setup. You can run it on a box that doesn’t have Chia software installed, and that further protects you from making any mistakes.

You are one of the most experienced people here, so we all look up to you, and hope that you will chime in when we are in trouble.

However, any, and I mean any decent software has two purposes: 1. provide some features, 2. protect the user from harming himself/herself. Any software that is using engineering logs, that are furthermore not easily recognized by the dev team that put them in a couple of months back, is just a joke.

We are all trying to help each other on this forum, where Chia Network is deflecting all shitstorms back to end users. Plus that is a company that got ~$60m investment just four months back (one engineer in Silicon Valley is about $200k/year), so not to hire people to beef up the UI, and still keep it in the alpha-engineering mode is just plain wrong.