Plots not showing in GUI

My GUI recently stopped showing my plots, it’s shows none at all like you’ve never added any plots. I’ve restarted the GUI 2 or 3 times and still shows the same. Moved the Config file so a new one was created added the plot directories back and still sits there and does not show any plots. Any suggestions or ideas on how to troubleshoot further?

Any errors in logs?

(20 characters)

What version of Chia are you running?

Does:
chia plots show
list your plot directories properly?

Try running:
chia plots check -g name_of_plot.plot
to confirm that chia is acknowledging the existence of your plot, and that your plot validates as good.

The results of the above could lead to identifying the problem, or narrow down the problem.

1 Like

Version 1.2.11, I ran plots check and it ran through all the directories and found the plots…were a few dead directories that I corrected the names.

Any specific errors I should be looking for, nothing jumping out as I looked through the INFO log.

Have you tried using the refresh plots button in the gui beneath add plot folder?

When you go to Plots tab, and click those three dots on the top right, then Add Plot Directory, do you see any folders there?

Yeah I have tried the refresh plots a few times, but after using hte check I just hit it again and going to let it sit for a bit. I know it takes awhile for it to show sometimes, there are around 4000 plots and 100 drives.

Yeah, the plot directory shows all the expected plot folders/drives that have been added.

In your debug.log you should have harvester output similar to this one:

2022-02-13T15:42:21.898 harvester chia.harvester.harvester: INFO     refresh_batch: event started, loaded 0, removed 0, processed 0, remaining 500, duration: 0.00 seconds
2022-02-13T15:42:21.991 harvester chia.harvester.harvester: INFO     refresh_batch: event batch_processed, loaded 0, removed 0, processed 300, remaining 200, duration: 0.02 seconds
...
2022-02-13T15:42:22.101 harvester chia.harvester.harvester: INFO     refresh_batch: event done, loaded 0, removed 0, processed 500, remaining 0, duration: 0.06 seconds

The first and the last lines show whether your harvesters sees any plots in those folders (e.g…, 500 in the above case). If you didn’t modify your rescanning times (directly in config.yaml), that output should kick in every 2 minutes.

Also, when you restart your chia, the very first (I think) such output should show what plots (including folders) harvester discovered.

If plot check sees those plots, it rather implies that you have reinstalled your Chia, and changed your mnemonics, as it looks like your setup is ignoring those plots as foreign ones (I think).

Closed the GUI, deleted the debug and restarted. On restart the harvester was finding the plots, I didn’t see the refresh_batch but looked like on initial start as you indicated it was pulling in plots in the debug file.

Maybe the very first one is not really refresh, but in 2 minutes after that, you should see it, and it should say how many plots were recognized.

Also, once harvester sees those plots, you can go to your Farm tab, and in the Last Attempted Proof, you should see something like 2 / 500 (the first number varies, the second is the number of plots your harvester works with). That should refresh every 10 seconds or so, and the second number should be stable.

Lastly, in that tab, at the very bottom click on Show Advance Options and you should have your harvester listed there in Your Harvester Network.

Actually, what is your pool saying? Does it show that you have some plots, or shows none.

Not really sure what triggered it, perhaps fixing some of hte missing directories, but it is now showing the plots and expected win times.

Really appreciate the quick support and guidance. I’m new to this and trying to get everything converted over to a new server.

1 Like

Yeah, that Plot Count number in the Farm tab is updated as the last one, and sometimes just takes a bit longer (minutes). However, the Last Attempted Proof should show the number of plots right after the harvester contacts your full node (seconds).

So, never relay on that Plot Count, always check those proof lines.

1 Like

Yeah working through all that now just trying to get a majority of my HDDs online, its quite the hodgepodge and my lookup times are already showing above 5s so may have to make some adjustments.

Also need to figure out how to install bladebit on my windows server.

Can you see the plots folders and the plot files inside?

Just as a follow up to nail down the exact problem that was causing my issue, I had a few directory shares that were network share locations on my server. Looks like for whatever reason when my server rebooted this network connection was not reestablished. So that seemed to throw the GUI for a loop and wouldn’t load properly. Once the connection was made to the network share on the server everyting seems to work fine.

1 Like