Plotting efficiency - Help

Hi All,

I literally know nothing about all this and started all in a rush but for newbies like me could anyone be kind enough to indulge my ignorance and advise on below, i feel that i got lost reading and trying to assimilate all this settings /options, I’m not so tech guy hence my struggle

OS: Windows 10 home
Gui: ver 1.1.7
Ploter Manager: PSChiaPlotter -
CPU: AMD Ryzen 3960x - 48 Threads
Memory: 96 gb ram
Temporary drives: 3 x 2tb NVME (1 Sabrent Q and 2 Samsung 970 EVO Plus) not in raid
Hard Disks:15 x 8 or 10 tb portable hdds all connected and sleep mode disabled

What is the right way as i cant get this time under 10h i was running 12 plots in parallel in different way (3 in pase 1, then another 3 after 32% and another 3 after 78% and Another 3 at 85% or should i run the plots at interval of 60 minute whatever i tried nothing diminished that time.

Any advice would be much appreciated on how to begin to optimize this beast.

The atached photo is a test plot i started now runing on a sabrent nvme with alocated 12 threads and 6750RAM and as you see the time is not great at all, phase 1 took 02 hrs 31 mins 33 sec

That doesn’t look bad to me. I get around 2:25 if I do one plot on my 3900x (6 threads… More does very little). I usually am around 2:50 when loaded up with 8-10 plots. Using wd sn750 1 tb.


I have almost a similar build and I get now 13 plots in parallels in less 10 hours, let’s say 9 hours and 49 mins (including all the time for the copy process for the 13 plots).

What I have and did:

Windows 10 PRO
Kioxia CD6-R SSD NVME 3.84 TB with PCIe GEN4 Adapter
Threadripper 3960x
Asus ROG Zenith II Extreme Alpha
Memory: 192 GB RAM, DDR4, 3600MHz
PBO and D.O.C.P enabled

13 plots in parallels
Delay: 1 min
RAM: 4000
Threads: 3

I don’t know if it can make a difference, but I would recommend you using Windows 10 PRO instead of Home.

  • Check the speed of your cores.
  • Check that the RAM frequency is set correctly in the BIOS for a better result
  • Check PBO and D.O.C.P

In you case I would not these 60 mins stagger. As you have a good processor, you could lunch all your plots in parallels with delay O or 1 min and try.
Maybe I’m wrong but you can try. I know there are other people here with more experiences that could help you. In my case, I continue checking how I can get a better result, for example having phase 1 below 13000s when I run my 13 plots in parallels with 1 min of delay. The best time I have for phase 1 is 13026s.

1 Like

So this where the problem lies, when i start adding plots

Now i added to que as per below:

1st series - 5 plots per Nvme with 160 minute stager,
2nd series - Nvme kicks in 20 minutes later with the same settings
3rd series - Nvme kicks in 45 later

All this is leading to a total of 15 plots each assigned 6gb ram and 12 threads

The below is the outcome over the night (3 plots done and the attached graphic)


As you have a good CPU with a lot of cores, I would not suggest you plotting staggering in that way you are doing.
You can easily make 15 plots in parallels with 0 min delay.
I don’t know what is the available space you have for each of your Nvme SSD, but let’s assume you can assign 5 plots for each one.
You can test doing the following:

1st series:
5 plots in parallel
Threads for each plot: 3
RAM: 4000
Delay: 0min
2nd series:
5 plots in parallel
Threads for each plot: 3
RAM: 4000
Delay: 0min
3rd series:
5 plots in parallel
Threads for each plot: 3
RAM: 4000
Delay: 0min

Test if you can and check the results.

Started this as advised and not looking good for the moment


In these screens, I can see some parameters you have. But what is your RAM frequency?

Hi again,

You can also get more speed for your CPU cores. I my case, I see all cores to run at 4.35 MHZ. You can test it when you can. It will depend on if you have good cooling. Just make a test when you finish these plots to boost your CPU using the AMD Ryzen Master: Creator Mode -->Manuel → set all cores to 4350 → Adjust the voltage (I can see in your screens you have already a good voltage 1.345v for this frequency, so no need to change) → and click on Apply&Test. Observe your system for about 10 minutes to see if it is stable and if the test is OK. After that You will plot a little bit better. But remember that RAM plays an important role in plotting. If you are not using the max frequency for your RAM (in my case I have 3600MHz), you will have to change it in the BIOS because sometimes the frequency is lower than that you have.


40 mins running 13 plots in parallel:
13 plots in parallel
RAM: 4000
delay: 0min
Threads: 3

1 Like

I think my ram’s are bit of issue i have various inside, and tryiet to overclock but i got lost as wasn’t working on the motherboard MSI TRX 40 10G

A1 - free Slot / A2 - Samsung / B1 - Corsair Vengeance / B2 - Corsair vengeance / C1 - Free / C2 - Samsung / D1 - Liber / D2 - Viper 32gb - Verde


I never use the mobo MSI TRX 40 10G. Maybe someone else can help you with it. Now your main problem is related with your RAM. If you want to plot better, I would recommend you DDR4 RAM with 3600 MHz at least to get a better performance. You will need to check your mobo for compatibility with some RAMs before doing any purchase. It is also better to get them with the same brand.

You can read this article: Does RAM Speed affect Plotting Speed on AMD? – The Chia Farmer

Hope this helps you.