Port 8444 is open but no incoming connections

Multiple port checker tools say my port 8444 is open, resource monitor agrees that start_full_node is listening on the port. I’ve disabled the firewall on my computer for good measure. Still I don’t get any incoming connections. What could be the issue?

I’ve got a real IPv4 and port forwarding is enabled on my router. Until recently I’ve had no issues.

If your running windows, chia asked to open the firewall for the chia app when it installed. I hope you answered yes. Thats all I had to do. Which version are you running?

1 Like

Is your router forwarding port 8444 to the correct IP address, and does your farmer have a static IP address?

to make the changes active you need to restart your computer. did you restart it?

I’ve tried 1.3.3 and 1.3.1 versions.

Forwarding is correct. My PC has a permanent lease for the address. My external IP changes sometimes, but not too often. I’d say once a month. Port scanners say the port is open.

I’ve restarted Chia, PC, and router multiple times.

It appears that peers do connect, but they disconnect shortly after.

he was asking if the farmer has a static address on the user side of your router I believe. My farmer node and my harvesters all have static IP4 addresses. keeps it way more simple as easy to track down problems.

Did you check the logs?

This is pure untested theory and I’m pooling so I can’t test. I’m wondering if Windows 10’s IPv6 preference over IPv4 could be affecting incoming IPv4 connections. We ran into something at work recently and M$ actually had us update the preference to IPv4 to make things work. Granted completely unrelated scenario but some recent update did change behavior within the OS.

My farm is pooling so I can’t test but below is a link for telling the OS to prefer IPv4. Again, pure theory and may not make any difference whatsoever.

I’ve backed up and deleted:


Then I’ve reinstalled and reinitialized. I’ve also changed my payout address and restored the db. Now I am getting incoming connections. How about that. At least I don’t have to sync from the start.


Not many people want to mess with the registry, So the easiest way is to just go into the ethernet adapter options select the lan port and properties select IPv6 disable (uncheck the IPv6 box) the click ok button. To check open a Command Prompt windows and run ipconfig to see that you only have a IPv4 address on that lan port.

Thanks to M$ and some change they did somewhere, that doesn’t work though. Go ahead and try it, then go to a cmd prompt and ping localhost. You’ll still get a reply on [::1], meaning the OS is still prioritizing IPv6 and using it.

I shut down a machine and then took the NIC out. Started the machine and then pinged the localhost and still got a response, Reply from ::1: time<1ms. Checked Device Manager and No Network adapters.

Well, yes, of course it still responds. Ping only goes down to layer 3. The command “ping localhost” asks the system to ping the loopback adapter which is good for what we’re looking at. We’re interested in the OS responding outbound on IPv4. If it’s returning [::1] it’s still preferring to use IPv6.

I want to mention again that I’m not sure whether the link I sent would resolve the issue for farming connections or not, but it’s certainly valid for telling the OS to use IPv4.