Problem syncing chia from downloaded sqlite db

How to fix this? I tried using my own DB and downloaded DB, non works

C:\Users\Me>chia start all
Daemon not started yet
Starting daemon
chia_harvester: started
chia_timelord_launcher: chia_timelord_launcher failed to start. Error: start failed
chia_timelord: started
chia_farmer: started
chia_full_node: started
chia_wallet: started

C:\Users\Me>Traceback (most recent call last):
File “D:\a\chia-blockchain\chia-blockchain\venv\Lib\site-packages\chia\server\start_full_node.py”, line 65, in
File “D:\a\chia-blockchain\chia-blockchain\venv\Lib\site-packages\chia\server\start_full_node.py”, line 60, in main
File “chia\server\start_service.py”, line 255, in run_service
File “asyncio\runners.py”, line 44, in run
File “asyncio\base_events.py”, line 642, in run_until_complete
File “chia\server\start_service.py”, line 249, in async_run_service
File “chia\server\start_service.py”, line 171, in run
File “chia\server\start_service.py”, line 135, in start
File “chia\full_node\full_node.py”, line 129, in _start
File “chia\consensus\blockchain.py”, line 113, in create
File “chia\consensus\blockchain.py”, line 125, in _load_chain_from_store
File “chia\full_node\block_store.py”, line 292, in get_peak_height_dicts
File “aiosqlite\core.py”, line 184, in execute
File “aiosqlite\core.py”, line 129, in _execute
File “aiosqlite\core.py”, line 102, in run
sqlite3.DatabaseError: database disk image is malformed
[14276] Failed to execute script start_full_node

If your DB is not working properly, best to just delete the whole .chia folder, blow away your config and sync from scratch. Are you aware there are 2 DBs (1 for wallet and 1 for the blockchain height)?

I had a similar issue and my issue was that my DB and wallet DB were copied from my server while Chia was still running. The only way to backup the DB and wallet DB is to quit out of everything Chia and then copy them.

2 Likes

Who needs sync? Both farmer and wallet don’t need it anymore so why bother.

Need to reinstall OS. Wallet DB synched fine. but not the main DB. synching from scratch would takes 2-3 days for me. are there any other ways around? I found some links to recently synched DB but when I tried to synched with mine it gave the error I mentioned

If you have one synced you can copy it, but as was said a few posts ago you need to end chia first as the databases are constantly updating, so if you try to copy them while they are active they will normally get corrupted.

I will add to my original statement on this. DO NOT download the DB (blockchain height) online. You don’t know if it is sketchy.

If you don’t have a system you can kill Chia and copy a .chia folder from, then best to just delete the .chia folder and let it be recreated then let Chia sync from scratch.

1 Like

Is it possible to sync a DB trhough the option Connect to other peers if the farmer is in the same LAN?

Not that I am aware of. Someone can correct me if I am wrong here, but I think it needs to sync directly to the master blockchain.

EDITED.

what do you mean by phone home?

It has to sync with the master blockchain. My choice of words was wrong there.

Have similar problem, since pc crashed… also made windows update…
now i have
Not accepting inbound connection: {‘host’: ‘81…’, ‘port’: 8444}.Inbound limit reached.
???

Somewhere ( don’t ask me where ) in your config .yaml you can limit / change no of peers in and out.

If you’ve reached your limit you should have easily enough to sync, so I’d personally just ignore that message.

1 Like

True. The DB from 3rd party sites are too crappy, or the DB of Chia itself is too sensitive, and would just show as corrupted when u run ur farmer. The best choice is to let it sync from the official channel albeit the long waiting time.