Problem with chia farming

From a last month I have big issues while farming chia. Basically it looks like that:

  1. Start chia
  2. Client is syncing
  3. Client is synced and start farming.
  4. For a while (4-10 hours) client stop farming.
  5. I go to see logs and there are multiple errors:
2022-01-03T08:25:20.867 full_node full_node_server        : ERROR    Exception: Failed to fetch block 1369381 from None, timed out <class 'ValueError'>, closing connection None. Traceback (most recent call last):
  File "/home/ubuntu/chia-blockchain/chia/server/", line 533, in api_call
    response: Optional[Message] = await asyncio.wait_for(wrapped_coroutine(), timeout=timeout)
  File "/usr/lib/python3.9/asyncio/", line 442, in wait_for
    return await fut
  File "/home/ubuntu/chia-blockchain/chia/server/", line 530, in wrapped_coroutine
    raise e
  File "/home/ubuntu/chia-blockchain/chia/server/", line 523, in wrapped_coroutine
    result = await coroutine
  File "/home/ubuntu/chia-blockchain/chia/full_node/", line 106, in new_peak
    return await self.full_node.new_peak(request, peer)
  File "/home/ubuntu/chia-blockchain/chia/full_node/", line 397, in new_peak
    if await self.short_sync_backtrack(
  File "/home/ubuntu/chia-blockchain/chia/full_node/", line 331, in short_sync_backtrack
    raise e
  File "/home/ubuntu/chia-blockchain/chia/full_node/", line 316, in short_sync_backtrack
    raise ValueError(f"Failed to fetch block {curr_height} from {peer.get_peer_info()}, timed out")
ValueError: Failed to fetch block 1369381 from None, timed out

If I try to restart my node (chia start node -r), I get:

chia_full_node: Exception ignored in: <module 'threading' from '/usr/lib/python3.9/'>
Traceback (most recent call last):
  File "/usr/lib/python3.9/", line 1428, in _shutdown
  File "/home/ubuntu/chia-blockchain/chia/server/", line 193, in _accept_signal
  File "/home/ubuntu/chia-blockchain/chia/server/", line 209, in stop
  File "/home/ubuntu/chia-blockchain/chia/server/", line 634, in close_all
    self.connection_close_task = asyncio.create_task(self.close_all_connections())
  File "/usr/lib/python3.9/asyncio/", line 360, in create_task
    loop = events.get_running_loop()
RuntimeError: no running event loop
sys:1: RuntimeWarning: coroutine 'ChiaServer.close_all_connections' was never awaited
RuntimeWarning: Enable tracemalloc to get the object allocation traceback
chia_full_node: started

Command “chia show -s” last forever and gives connection error.

Connection error. Check if full node rpc is running at 8555
This is normal if full node is still starting up.

The only thing that helps, is to restart my pc. But after few hours same story.

I use raspberry 4 as farmer with Ubuntu 21.04. For wallet and node database, I use WD Green SSD.
Has anyone had a similar problem?

Sorry, I have only used Windows with Chia so far. Do you have enough space? user rights etc?

Do you have any drives that go to sleep ( you said GREEN DRIVE)?

I have 200GB+ space left for database. User rights are ok.
Yes, that green drive might be a problem. Good idea. I’ll check it out.

1 Like

That SSD should work if Chia client is constantly using him for node database. I move my database to that SSD, 15 days ago. The problem starts before DB migration.

I turned off all my hard disk settings to never idle or sleep also goes for the USB ports.

Here is the same problem ([BUG] Cannot connect to host ssl · Issue #7458 · Chia-Network/chia-blockchain · GitHub).
The only solution I found is to downgrade the client to version 1.2.7. Seems to be working.

chia stop all -d

git pull
git checkout 1.2.7

. ./activate
chia start farmer

keep us posted! it’s interesting is the issue is really in a new versions and you just need to downgrade

I think I may have found the issue with this problem. Power and sleep settings. set hard drive to never sleep. Also Sleep function and hybrid sleep need to be disabled in the advance power settings. These settings can be a little hard to find in windows 11, they are there and can be found by searching in the taskbar for “Power and Sleep”.

Let me know if my solution was a hit or miss.