PSA: Update your NVME M.2 drive firmware!

There was a Samsung 980 Pro firmware update specifically about Chia plotting, so it’s a good idea to update your NVME drive firmware if you haven’t!

Here’s a link to the Samsung Magician which lets you update the firmware:

I am doing this on my plotters as I can… since this update was specifically Chia plotting related as I understand?

If you have another vendor / brand, please link to the page where you can update / check your firmware too!


If you have OEM version like PM9A1 that isn’t recognized by Samsung tool, Lenovo firmware bundle may help NVMe Solid State Drive Firmware Update Utility for Windows 10 (64-bit) - ThinkPad - Lenovo Support AE


The Samsung Magician is also handy since it can tell you if the drive is connected in a way that offers less bandwidth, as well as drive health and other SMART type stuff:

Here you can see at upper right this drive is connected as PCIe 2 x 2, which I didn’t realize, and would affect perf!

I don’t know if the “performance optimization” here is worth it either. But you can turn on a “full power mode” which

Full Power Mode allows the SSD to run at peak level (PS0) for nonstop consistent high performance

requires a reboot though!


If you are running Linux and/or an AMD platform, the Samsung boot ISO is horrible. I’ve written a little post on how you can directly update the firmware from within your own Linux install.


Awesome, thank you!

Has any one had any luck running this on their boot device? (which obviously can’t be unmounted :slight_smile: )

1 Like

I ran into this issue today updating a couple of my 980 pro 500gb that just came in before seeing your post. I had to move the drives to another computer and it updated successfully over there :joy:

Anyways after updating and on Ubuntu I am still seeing only 500MB/s write speed… Read is exactly as advertised around 7 GB/s. Is there anything else I need to do? I am getting these values using Ubuntu’s disk utility benchmark that’s built in.

1 Like

Thank you so much @Quindor . This was incredibly, enormously helpful!

I ran it successfully on both my 980s (including the boot drive).

I know, I rolled the dice on that one… but it seems to have worked ok!


Just to follow-up to myself… threw the 980 pros into a Windows 10 machine and it’s blazing fast.

1 Like

Dude, thank you so much for this. Did it last night and it was super easy!

1 Like

Thanks. Worked beautifully. Samsung 2TB 980 pro humming.


I bought a new Samsung 980 Pro 1TB M2 NVMe and updated it with Samsung Magician while plugged into a Windows machine. Benchmarked it and got 3243 Read/2999 Write on there. Have installed that in my plotter into PCIe x16 slot and getting only 580MBs using Ubuntu’s in-built benchmark. It’s an older machine but got plenty of cores and RAM.

CPUs: E5-2650 V2 ( 2 x 8 Cores/16 Threads) @ 2.6Ghz
RAM: 192GB DDR3 @ 1866 Mhz
OS: Ubuntu 20.04.2 LTS

  • Disk /dev/sdb: 931.53 GiB
    Disk model: Samsung SSD 860

  • Disk /dev/sda: 931.53 GiB
    Disk model: Samsung SSD 840

  • Disk /dev/nvme0n1: 931.53 GiB
    Disk model: Samsung SSD 980 PRO 1TB M2 NVMe
    Mounted with:

sudo mount -t xfs -o discard /dev/nvme0n1 /mnt/nvme0n1

num      job       k    pid           start          elapsed_time   phase   phase_times   progress   temp_size
1     EVO1         32   4677   2021-05-22 16:07:36   00:47:24       1                     11.67%     126 GiB
2     EVO2         32   4678   2021-05-22 16:07:36   00:47:24       1                     12.34%     131 GiB
3     980ProNVMe   32   4679   2021-05-22 16:07:36   00:47:24       1                     12.15%     130 GiB

To say I’m underwhelmed is an understatement as the NVMe is getting beaten by a years-old SSD. Any ideas to improve plotting speed? Thx.

Ubuntu’s built in benchmark tests both read and write at the same time no? Use FIO and do sequential tests.

1 Like

I think this is the correct command based on your suggestion. Still looking bad.

fio --randrepeat=1 --ioengine=libaio --direct=1 --gtod_reduce=1 --name=test --filename=random_write.fio --bs=4k --iodepth=64 --size=4G --readwrite=write
test: (g=0): rw=write, bs=(R) 4096B-4096B, (W) 4096B-4096B, (T) 4096B-4096B, ioengine=libaio, iodepth=64
Starting 1 process
Jobs: 1 (f=1): [W(1)][100.0%][w=425MiB/s][w=109k IOPS][eta 00m:00s]
test: (groupid=0, jobs=1): err= 0: pid=16392: Sat May 22 18:01:19 2021
  write: IOPS=104k, BW=406MiB/s (426MB/s)(4096MiB/10091msec); 0 zone resets
   bw (  KiB/s): min=254008, max=452392, per=99.95%, avg=415420.20, stdev=41903.25, samples=20
   iops        : min=63502, max=113098, avg=103855.15, stdev=10475.77, samples=20
  cpu          : usr=19.58%, sys=51.34%, ctx=976647, majf=0, minf=103
  IO depths    : 1=0.1%, 2=0.1%, 4=0.1%, 8=0.1%, 16=0.1%, 32=0.1%, >=64=100.0%
     submit    : 0=0.0%, 4=100.0%, 8=0.0%, 16=0.0%, 32=0.0%, 64=0.0%, >=64=0.0%
     complete  : 0=0.0%, 4=100.0%, 8=0.0%, 16=0.0%, 32=0.0%, 64=0.1%, >=64=0.0%
     issued rwts: total=0,1048576,0,0 short=0,0,0,0 dropped=0,0,0,0
     latency   : target=0, window=0, percentile=100.00%, depth=64

Run status group 0 (all jobs):
  WRITE: bw=406MiB/s (426MB/s), 406MiB/s-406MiB/s (426MB/s-426MB/s), io=4096MiB (4295MB), run=10091-10091msec

Disk stats (read/write):
  nvme0n1: ios=2525/1029235, merge=0/4, ticks=146/48270, in_queue=48429, util=99.07%

Well, if it benches OK in Windows, then it has to be something specific to that Ubuntu machine?

Anyone find a solution to this? Even with the new firmware I can’t hit more than 600MB/sec writes in ubuntu (but reads are 7000MB/sec). I’m beyond infuriated. Should have gotten the rocket 4 plus over this garbage drive.

Found and applied latest F/W Feb 22 update for my PM9A1 2 TB
zip also contain the same for other capacities:
GXB7601Q : 2 TB
GXA7601Q : other

Samsung SSD Manager Version
Copyright (C) 2019 SAMSUNG Electronics Co. Ltd. All rights reserved.

| 1 | O | NVMe | SAMSUNG MZVL22T0HBLB-00B00 | xxxxxxxxxxxx | MZVL22T0HBLB-00B00 | GXB7601Q | Inbox | Normal Mode |

See forum here : Samsung 980 Pro Treiber Frage ( PM9A1 Firmware OEM, Write Performance Fix) | Seite 21 | Hardwareluxx