Recover wallet by damaged hdd

Hi all, first post here :slight_smile:

I tell you my situation…

The hdd where the chia software was installed ran out of space and I installed a 2tb hdd to move it there with the help of these steps from the reddit forum:

Close Chia then move the two directories for Chia manually first, which are usually found at:

Then in CMD follow the command structure and make a symlink for both locations

mklink /J currentLocation targetLocation

So it might look like this

mklink /J C:\Users%USERPROFILE%.chia D:\Chiacoin.chia


mklink /J C:\Users%USERPROFILE%\AppData\Local\chia-blockchain D:\Chiacoin\chia-blockchain

Open Chia and it will recognize everything like normal.

Now, the 2tb hdd is dead but the software remains installed on the pc…

I have my seed and I have a new hdd but the question is, can I recover the wallet?

I have to uninstall the software?? (The exe gives me an error when I run it because the path is that of the other hdd…)

It is possible to reverse the process that I have put above so that it is again in c:\ ??

Any answer is appreciated, I have a few chias there and… uff xD

Thanks and regards :slight_smile:

Yes, your seed controls your keys, just do a fresh install on a good drive, use that seed, sync it and your good.

Or use the light standalone wallet on a drive that doesn’t have chia installed on it, use your seed, let it sync.

Don’t worry, your funds are safe.

I’m sure you probably can reverse what you’ve done but personally I’d just start over with a fresh install.

I’ve nvr used symlink, so not the best person to answer this.

1 Like

Its good to try things, I would have copied the image (using Acronis) to that new 2tb (1.81TB) and keep things more simple to keep track of.

1 Like

Just as @Bones said.
All u need is ur Seed.
For a fresh install on the old system, just delete everything, especially the symlinks, and ur good to go.

1 Like

Hi, thanks for the answers…

I have made a new installation of chia and I have been able to recover the wallet and the plots but I have 0 XCH. I guess that I have to wait for it to fully sync…


And now that I look at it, I’m not in the pool… If I click on join, asks me again xch…

Not fully, only up to the height your blocks were found that rewards were payed on.

1 Like

Wait for it to sync up to the height you joined the pool on. Don’t join again because this will create another Plot NFT your plots won’t work with. It will be all right, just patience.

1 Like

Ok, mode waiting then xD

Thanks :slight_smile:

So now you reinstalled chia on the hdd that filled up before?
Won’t his happen again as the blockchain db grows (up to ~65GB at the moment and growing every day)?
Is this actually a HDD or a SSD?
Syncing from height 0 takes a long time anyway but on a HDD its gets even worse.

That 2TB disk, did it die totally? Would be great if you could somehow retrieve the database files… but dead does not sound good :roll_eyes:

No no, that hdd died (nvme). The data is unrecoverable. I installed it because on the 128gb ssd there was no more space for that reason, because the db was growing, that’s why I did the mklink… The new is nvme too…

1 Like

Hi again, the node reach the height but from yesterday its in red color “not synced” and the plots are in “not available” status…

I must have to do something else ??

Regards :slight_smile:

Did you try stopping and starting the software again.
Mine does it regularly ( being synced but not farming ).
Oh the joys of running a chia node.

Ah, your not synced… I also get this…
Still, try restarting software, if still not moving try deleting unconfirmed transactions.

1 Like

I restart the software and now its syncing again…

I wait, to see what happens…

Tx, Bones :slight_smile:

1 Like

When I looked to see how it was going I saw that the gui had closed, I reopened it and in less than 5 minutes it closed again… I’ve restarted the pc to see what it does now… Weird, no ?


Well, the software doesn’t stop, no, the pc restarts… Is there some kind of bug in 1.2.11 ?? With 1.2.0 this did not happen…

I’ve never had my pc restart except for bsods and updates, so I doubt this is chia related.
I’ve seen others complain of it but never personally experienced it.
I’ve been on .11 for a long time.

It’s just that it’s very strange, Bones… Fresh installation of win, fresh installation of chia, only that software running, no heating problems, 2 psu…

I just installed 1.2.0 to see what happens…

Besides, it never gets to sync at all…

1 Like

If you’re considering doing a fresh install of the full client, you may want to consider using our Chia blockchain bootstrap to speed up the initial sync process!

Hello, well, it seems that everything is stable since I removed the second power supply.

I left only 8 hdds with one psu and it didn’t restart or anything, I added the other 8 hdds and at the moment, everything works fine and synchronized ok, with all my chias in the wallet…

@elysiumpool Thanks for the info, for the next one :slight_smile:
Regards :slight_smile: