Reload... force reload.. reload.. force reload

Frustrating chia software… reloaddd… shutdownnn…delete db filess… reloadddd… force reloaddd… nothing…

1 Like

You are the only peep I have heard complaining about repeated re-loading in many months.

This is not a Chia problem. This is a user problem.

Why are you deleting db files and reloading repeatedly?

What problem are you trying to solve?

3 Likes

Really? I read it all the time… This is NOT a user problem. It’s Chia software. It was working… I just shutdown… and it took very long for the that Connecting to Wallet… like hours still connecting to wallet… so have to reload… or force reload… sometimes it opens but you’ll just see those loading circles… blah blah… don’t say about user I’ve been with this since March and I’ve experienced and read many issues of this sort… still no good…

Why would I not click Reload… or Force reload if this picture keeps going on for very longggggg

Be ready, he is about to count threads you’ve started :laughing:

1 Like

I have experienced something like this recently jeblumena, but let’s look at this clearly, and calmly. Here what happened on my setup, maybe it’s like yours? One dif is I’m on sw ver. 1.2.10dev13, not 1.2.9

Anyway, so GUI is open for days let’s say or maybe not, don’t think that’s important. I want to shutdown so, close, and restart. At that point, I never get past that big circle to start. So after a while, I close, but the little closing panel doesn’t go away. I ‘x’ it away. Try to restart GUI again … same.

So I’ve learned that if I do a cold shutdown, restart the PC, then it will generally work. It almost seems like it can’t connect? I watch and the cpu threads are doing smthg, just the GUI is stuck. it just doesn’t get anywhere.

Maybe we’re the only ones. But seems unlikely. I’m mean it’s not killer, just inconvenient … once over that hiccup, all is fine.

ps. I’m unclear why you need to delete db files if you never get past the circle spinning?

1 Like

Most peeps do not have to sit there with the wheel spinning for hours. Most peeps load the GUI in under a minute with less than 30 seconds of the Connecting to Wallet circle. If this is happening to you then you have a problem. Re-loading will not fix your problem.

This issue and the answer of deleting your DBs has been discussed, but not much recently as it is long solved. The only recent thread similar to this issue turned out to be a peep pushing his Pi too hard. I don’t think this is your problem, lolz!

So you shut down and have the circle for hours after re-starting.

The solution was posted by the devs (mariano54 is on the Chia Team at Keybase) on May 4. After having the issue myself and finding this answer I shared it here in June.

In another recent thread you said:

"jeblumena Aug 29

The blockchain db I think is corrupted due to sudden loss of electricity.

It’s been 24hrs and still syncing kind of broken. I think it’s faster to download the db than to sync it."

So this is a new problem that started after a power fail?

Did you end up downloading the blockchain? If you tried, then this is almost certainly your problem.

You can download the blockchain instead of syncing but I do not recommend doing so as there are security and corruption issues.

You cannot download your wallet db as it is your wallet db. Everybody shares the same blockchain but they do not share wallets. Your wallet is part of the blockchain. You can save your wallet db and re-install it, but you cannot download it from someone else. The only way to re-build your wallet db if it is corrupted or gone is to re-sync it by re-syncing the wallet with the blockchain. Your GUI has to go through the entire blockchain to create your wallet db transaction by transaction. This does not cause the GUI to hang connecting to wallet.

If you downloaded a corrupted blockchain your wallet not syncing would make perfect sense. Properly re-syncing your blockchain and wallet takes hours to days depending on your processor and connection, but it is time well spent.

You said you had deleted your wallet db. Did you do it using the process described by mariano above? How long ago? Have you upgraded the GUI since? Does the problem persist after you have upgraded the Chia Client and properly deleted the wallet db? If so, are there any in ERRORS in your log? Is your log set to INFO?

Be well.

I discovered the issue I had when shutting down (and not restarting, just getting spinning) was one of patience with chia GUI sw components. So I needed to shut down agin, did that the normal way, but the smaller closing panel wouldn’t close. So instead of 'x’ing out the panel and immediately trying to restart, I opened task mgr and found chia still running. I just waited…and waited…seemed like a couple minutes and *finally they disappeared from task manager.

Then it would restart. Odd behavior I must say.

Actually, when closing chia, I always watch in Task Manager / Processes for chia related processes, and if those are trying to hang out there, I help them to exit. I know, terminating a task that still has something to do (e.g., update the db) is most likely not safe. However, my take is that if those are not closing for such a long time (seconds), it is most likely due to broken synchronization between them, as they are waiting on some sort of events that will not happen anymore.

Also, there is no difference between box restart and terminating those processes (the latter is faster, though). Therefore, if Chia survives those reboots (no one complains about that, AFAIK), it also will survive those terminations.

I guess, the problem is that when you start a “new” instance of Chia, it is not trying to see whether there are some leftover processes, and doesn’t give you a choice to kill those, or abort the startup process. Therefore, after such failed start all synchronization is broken, thus that forever spinner.

Mine spins for 20 / 30 mins every startup, I just wait, it always resolved itself.
Possibly I corrupted something long ago when I got bored of waiting so closed it, then force closed the smaller popup.

I would not think that you corrupted something, but rather software went to a bad state and no matter what you would be doing, you were just doomed. The fact that we have this thread is due to poorly written exit synchronization, not us trying to close that program.

In my case, when I help Chia to shut down, it takes about a minute/two to dismiss that spinner. However, when I immediately shut it down after such start and restart, it is ready in about 10 seconds or so. Actually, after I wrote that thing above, I needed to restart it, but it got stuck again (so had to do that maneuver again). I had it running for few weeks, and it kind of looked to me like there were just too many of chia processes there. Maybe it just deteriorates with time, and start spawning additional processes from time to time (when some processes stops responding??).

How big are your blockchain and wallet dbs? My blockchain is a bit over 24GB, and wallet over 6GB. Do you have them on an SSD/NVMe, or HD?

Just woke, another issue to fix.
I’ll try to come back and answer this later.

Blockchain sqlite is just under 24gb ( below yours due to not running for just over 12 hrs… the new problem )
Just deleted wallet so can’t say.
On hdd.

Without b/c dB there it loaded superfast.
Put it back waiting again lol.
Need to get it onto ssd me thinks.

Assuming the worst case that the whole b/c db needs to be read, that will take some time (e.g., copying a plot takes 10-20 mins, this db is a quarter of that). Once it is read, it needs to go to your RAM, and I assume you have a lot of swapping going on. So, that will further slow your loading times.

If you have any SSD/NVMe on that box, what you could do is under Advanced System Settings / Environment Variables point all four temp variables to that SSD. Also, under … / Performance Options / Advanced / Virtual memory remove your swap file from that HD, and set it to be on your SSD. Those two may help with the swapping a bit.

My box has 16GB RAM, and OS is on a standard SATA SSD (~500MB/s), the CPU is a mobile i5-8250U. It mostly runs with single digit percentages for CPU, plus reduced clock rates. Since you are already thinking about getting a new box, I would just get an SSD first, and move OS to it. Afterward, I would check whether you can add a bit more RAM. I think that is the problem with your startup, not really a corruption of that db.

Thanks, there’s minimal ram in that box, 8 gig that’s pretty slow, I do have a sata ssd laying about though.

TBH, I think I’m just gonna fresh install on my plotter tomorrow, I’ve deleted dB files except the b/c 3 times now as whenever I boot up I get loads of messed up logs that don’t quit.
Can’t connect to my own wallet, ssl error, only gets resolved after deleting files, next reboot its f****ed and.
Don’t think I’ve prop farmed in day.
Updated to 1.2.9 , not helped a bit.

I am still on v1.2.6. I am itching to update, but … Maybe, if there is nothing in v1.2.8/9 that you badly need, you could downgrade to v1.2.6? Looking at changelog, v1.2.7 should be also safe.

They did some new work on wallets in v1.2.8-9, maybe that is a part of the reason for your problems? Apparently, v1.2.8 was badly broken, and v1.2.9 came just day after that to quickly patch things up. This to me implies that only critical issues were fixed, as they were pressured to deliver fixes for what was known at the moment (just one day in the field).

Actually, after installing .9 and deleting all but bc dB, it’s looking better, farming again for now.
Some really bad spendbundle warnings, block validation times. ( 5 to 10 sec)
Still gonna fresh install on plotter, if it runs well on there and sata ssd I’ll def buy new box.

Is your sata ssd m.2 or normal sata connection?

That box is Gigabyte Brix i5 8250 - a very small NUC. Virtually no expansion capabilities. It has 2x USB 3.0 and 2x 3.1 (one is type C). I have 20 HDs connected to those 3.0 ports. OS is on normal SATA connector (2.5"). Although, it also has m.2 (I tried to use it for plotting using that m.2, but the top mounted fan was lifting it off the table and aluminum heatsink started to melt :wink: It can take 32GB RAM, but I only have 16GB (used to be just 8GB, but I added one more stick when I used it for Chia).

Although, it is a nice little box for non-demanding tasks.

I also have another Gigabyte Brix with Intel J4105 (low power Celeron). The CPU is really weak, but works well as a harvester (again, only for USB drives).

This post was flagged by the community and is temporarily hidden.

Download a zip file with, “disk accelerator” and install it?

You must think we are stupid.

3 Likes

Especially from Yandex.

2 Likes

I had to restart that box one more time (to enable TPM - Win 11). This time, I was paying a bit more attention to Task Manager. Until that spinner is dismissed, my OS SSD was fully choked. Once SSD reads stopped, the wallet UI was presented. So, looks like it does read that full db, and is choking during that process. Although, as that is only on startups, I would not bother to waste money on NVMe, as otherwise that SSD is basically idle. So, whatever SSD you have on hand right now, it will make it much faster.