Slow plotting. Help needed finding the bottleneck

Hey community,

I finished assembling my rig this weekend (following Build a Budget Chia Cryptocurrency Plotting Rig - guide).

My current setup:

  • ASROCK H470 mobo
  • 1TB nvme + 2TB nvme (inland premium). I mounted these two as raid0
  • Intel i7 10700k
  • Exos Seagate Enterprise HDDs (few 16TB, one 18TB) + 1 WD Purple 8TB

I’ve been running around 3-4 parallel chia plot processes with the following params - chia plots create -k 32 -b 4000 -e -r 4 -u 128 -n 16 -t /mnt/ssd/temp1 -2 /mnt/ssd -d /mnt/hdd.

Checking logs for “Total time” I see 49716 and 64073 seconds (2 plots generated). My CPU and RAM always seem to be underloaded. Any hints what could be the bottleneck and which part of my rig my I test?


1 Like

That’s seriously slow indeed.
The system (hardware) doesn’t have any bottlenecks that I can see. If anything you have a bit more ssd space than needed but running in Raid should help the transferspeed so it’s not really a waste or anything.

The problem must be in either the computer configuration, or the plotting command you’re using.
I don’t use the command line myself so can’t really help you there.

If you’re running in Windows I would just try to run a few plots from the Chia software and see how that goes.

1 Like

Oh, I forgot to mention - I run on Linux Ubuntu 20.04 LTS. The results I posted were prior to me mounting the 2nd nvme (so I had only 1TB of nvme, which, I don’t think would impact drastically the plotting time, and would rather be a limitation in terms of how many parallel processes I can run). Now as I attached the second nvme (2TB) and raid0-ed them together - I’m running 8 processes with 1hr staggering. Will report back the results in the morning (if I even get any plots by then :smiley:).

1 Like

Hi @eve_collins, just by way of comparison as i have a similarish set up.

some gaming m/board from asus,
16gb (2x8 sticks)
1tb samsung 970 pro m.2 nvme sdd for temp folders
currently sending to a 10gb usb-3 seagate for storage
running the gui on windows.
3 plots in parallel at around 4.5-5.5 hours per plot.
settings are standard except upped the threads to 4

I am also mining eth on a rtx 3070 at the same time.

Wow, that’s more than 2x faster than what I get :open_mouth:

everything looks good, only thing I see is that you have disabled bitfield plotting -e, this is no longer as efficient as enabling it, I would suggest to run the command as follows:

chia plots create -k 32 -b 4000 -r 4 -u 128 -n 16 -t /mnt/ssd/temp1 -2 /mnt/ssd -d /mnt/hdd

1 Like

i think i’m getting lucky as i have no idea what i’m doing really… not changed any settings on anything… i had to google how to add the nvme drive as i really am a noob at the hardware stuff.

1 Like

Thanks. I’ll try enabling it, but I’m skeptical it would lead to 2x plotting speed increase.

I think you will se a difference. my understanding is you only disable it for old cpu’s.

There is also something you need to do with the ram (i think) for linux you don’t have to do on windows… there are some threads on slow plotting on the forum.

what is your latest update on this.
With this kind of set up, I guess that you should get around 20 plots or more per day.

I’ve been running 8 processes in parallel with 1hr staggering (the way it’s described here - Build a Budget Chia Cryptocurrency Plotting Rig -) for the past 10 hours, and I got 2 plots, which seems very low. Currently I’m at 2TB space used in my temp ssd, 100% used SWAP (do I need to disable it?), 54% cpu and 84% ram usage. Any ideas?

8 might be pushing your RAM limits. Also, RAID 0 on the 1TB+2TB … not sure this has any performance hit since they aren’t matched? Really should try one at a time to pin point if parallelism is an issue, or there’s something fundamentally wrong.

Dunno how the other person is getting 3 plots in 5.5hrs… seems crazy? I’m doing around 28-30k with 5 going, 4 to one NVMe, 1 to an SSD. Even solo I was only getting 25-27 to SSD =/ (3600/32GB). I have an old i5 6500 to an SSD getting around 25k ( SSD, single plot).

I don’t recall where I read it, but there was another post about trim settings in linux that might not be on by default?

I believe that “trim” is being enabled by mounting the disks with “mount -t ext4 -o discard /dev/sda2 /mnt/ssd”. Per RAID0 on the SSDs performance - is there a way to measure the performance of that raid? Trying it with just 1TB was clearly slower, giving me those numbers I posted in the original message.

Now, with 3TB ssd, I got one of the plots generated in 24k seconds. But I’m still surprised I only got 2 plots within 10 hours of running those processes (even with 1hr staggering period).

Not familiar with linux enough. Though, your OG numbers were in parallel, not just a single plot?

Also, did you raid0 and end up with 3TB? I didn’t think you can do that?

Well, the numbers were from one of the processes. Even though they were running in parallel, one of them produced a plot in 49k seconds and the other one in 64k seconds. Which got significantly better when I added the 2TB ssd.

Oh, and yes, you can raid0 ssd’s of different capacity.

my point was more to run solo to eliminate any other possible variable. even if they were going to different drives (and even more so if they were plotting to the same drives).

how does raid0 w/ different capacities work to get you 3TB? There isn’t physically an even stripe?

I’m not sure, but I previously created a raid0 with a bunch of HDDs of diff sizes (8T, 16T, 18T) where I was going to store my plots with no issues. Although I then thought its a bad idea, given that a single failed HDD will ruin the entire raid, so I un-raided them.
So same approach worked just fine with the 2 SSDs of diff sizes.

Hm, I could run them solo, but I’m not so sure it will make difference? I can definitely try it. Do you know if there’s any way to measure the IO performance? I could measure it for raid0 and then measure for two solos.

I agree with above, time to eliminate possibilities.

  • revisit the bios settings
  • take out one of the drives, reformat, retrim and try with just one disk in the primary slot
  • still shit, then try different OS/distro

I’m getting 33000 second on my ryzen 2400g office pc, plotting 2 parallel on an external ssd…so an i7 with nvme drives should just really do better than that.

Any suggestions on what exactly to look for in bios?

Are you getting 33k seconds per each process? So 2 plots per 33k seconds?

No I mean 33000 second per plot XD

For BIOS: RAM speed, XMP, dual-channel, just check if it’s all running correctly,
CPU settings, speeds etc.
See if the nvme drives are recognized properly
Or just reset the Bios and start over :slight_smile:

If there is Bios update, you should do that as well

1 Like