Slow plotting nvme on Mac m1

Using 2 ssd (for now) on Macbook Pro M1 (16GB).

  1. sandisk extreme 1tb (up to 1000mbps write (via TB3 have 700) but realistically get 300 mbps write max via usb-c dock). Use via usb-c dock, so 300 mbps write.
  2. Samsung 980 pro via TB3 enclosure. Realistically have 1200 mbps write (4x times more than sandisk). Upgraded firmware to the latest one (to fix known write speed issue).

I run 2 plots in parallel on each ssd (3600 mb ram, 2 threads) to check how will it go.
So far, much slower sandisk finished plots faster. During plotting samsung ssd had much faster write speed (was continuously checking via Blackmagic).

I am lost and looking for advice. How to understand why much faster ssd is so freaking slow in plotting…

Hopefully, someone will reply with a more technical explanation but focusing on the sustain write speeds listed on the spec sheet is key. Plus, Tom’s Hardware has diagrams and articles/graphics, deeper explanations, etc. I’ve found great success with the following SSDs:

  • Samsung 970pro 1TB (longevity)
  • Seagate Firecuda 1TB (recently gave trial run Thanks to @ MontyBurns, and it seems slightly faster than Samsung)

I’ve tried the ones below but decided to move forward with those two above:

  • Samsung 970evo plus
  • Samsung 980pro $$$

The SSD enclosure and connecting cords matter too. I went with OWC Envoy express and the UGREEN SSD Enclosures for my now ~100 TB farm.

I unearthed my first pool block on August 25th in the AM with less than ~50TB farm, so don’t get discouraged.

The M1 w/ 16GB running just the GUI set to “plot in parallel” w/ plot count (29) a delay of (107mins to 80mins) varies, and I do max RAM usage of 5200RAM + number of threads used (6) ought to plot between ~13 -18 plots per 24 hours.

Hopeful this helps!

The Seagate Firecuda 520 does 2800MBps sustained with Blackmagic speed test, but BM speed test is sustained read/write speed on 1GB + files. Chia plotter is reading and writing much smaller files so BM speed test is by no means an accurate speed indicator for plotting.

I first started plotting with 2 Samsung 960 EVO 2TB SSDs in a TB1 enclosure with RAID 0 on the M1, it BM benched at around 700MBps, and it plotted much slower than the Firecuda NVMe in a TB4 enclosure. Something like 6hrs per plot vs just over 3hrs.

Acasis, the TB4 enclosure vendor advised which NVMe to use with their enclosure:
Not recommend SSD: Samsung 970 EVO plus / Samsung PM981 / WD SN850 / ADATA / CRUCIAL
Recommended SSD: Samsung 970 EVO / Samsung 980 Pro /SEAGATE 510 series

So it appears Thunderbolt enclosures are a bit finicky with NVMe

And yeah, cables matter. Thunderbolt 3 and USB-C cables look similar, but they’re wired differently.

I’m just waiting on another Firecuda to arrive. Curious to see if running 2 of them in a RAID 0 can plot more than 18 per day on the M1.

@jazsimps Keep an eye on swap use in the activity monitor. If you’re allocating 5200 ram, you might be slowing plotting down a bit. Even with 3390 ram, my swap is usually around 2-3GB while parallel plotting batches with 80min delay + a web browser running. Swap use appears to have increased a bit between 1.2.3 and 1.2.6

1 Like

I’ve noticed that similar swap range and will keep an eye on it while using the higher RAM configs.

My experience has been ~1GB or less. But towards the end of a batch (29 plots), it drifts closer to 2GB. Usually, I complete a CPU & SSD reboot/erase on the plotting rig when I can remember before running the next batch.

So, I ordered the Acasis enclosure to benchmark it, and this Acasis, the 5th enclosure for me, should arrive later today. I will initially set the RAM at 4000/3500 instead of the 5200 to minimize the swap concerns, Thanks!

Occasionally, the cord that accompanies the enclosure can be problematic accidentally disconnecting mid-batch due to a less-than-snug connection (perhaps wear & tear overtime) or when I happen to bump or move the rig during the plotting process. There’s also other random tinkering with it, so that’s the reason I tested out the OWC enclosure, but once I observed the dip in plotting speed… I continued trying out other enclosures.

I’ve also either used or currently using one of the 5 following SSD enclosures listed in order of purchase:

 1) Sabrent USB 3.2 Type-C Tool-Free Enclosure < returned >
      Thunderbolt 3 compatible
      M.2 PCIe NVMe and SATA SSDs (EC-SNVE)
      ^ I experienced extreme heat with this enclosure.

 2)  Sabrent Thunderbolt 3 Enclosure < returned >
       Tool-Free Solid Aluminum (EC-T3NS)
      ^ I experienced disconnection issues personally with this one.
 3)  OWC Envoy Express SSD enclosure  < returned >
       Supports up to 1553MB/s real-world performance per the website.
       ^ I liked that the cord is solder onto the enclosure.
       ^ I experienced overall slower speed of plotting concerns with this one.

 4)  UGREEN M.2 NVMe SSD Enclosure  < 2x currently >
       USB C 3.1 Gen 2 10Gbps  
       Thunderbolt 3 Compatible
       ^Slower but has been rock solid for me in regards to heat/cord concerns.

 5)  ACASIS NVME Enclosure  < 1x ordered probably order a 2nd unit >
      Tool-Free Solid Aluminum
      40Gbps Support SSD Size 2280
      Thunderbolt 3 TYPEC M.2 USB 4.0 Adapter

The cable that came with my Acasis enclosure fits snugly. Can’t say the same about the OWC TB3 hub :face_with_symbols_over_mouth:

The Acasis will run a few degrees cooler if you stand it on its side vertically, I stuck mine to an NVMe heatsink wit a thermal pad, it’s running at 52ºC; sitting flat on a desk it got up to 62ºC.

Is the M1 Mini your farmer? I’ve got 24 drives connected to mine. Since I connected a bunch of drives, every couple of days my wireless keyboard goes crazy, and I have to reboot. Trackpad and wired keyboard work fine though. It appears the Mini either runs out of power or has a device limit if too many 3.5" external drives are connected with passive USB hubs, so I got a 16 port Acasis USB-3 hub (same as the Sabrent one) and an OWC Thunderbolt hub.

The Acasis enclosure’s solid build and performance have been excellent thus far @MontyBurns , a week or so out the gate. Although it’s pricey, I’m buying 2-3 more.

I have an i7 model as the farming machine and a small farm of triple M1s as plotting machines. My bottleneck is not so much speed of plotting for me, but how willing am I to purchase more HDDs vs. simply accumulating Chia coins directly via KuCoin at less than $200. lol

By chance, I was able to snag an Acasis enclosure below the current retail price. I currently use the Sedna 13 Port USB 3.1 Gen I Hub (5 Gbit/s) - 19 Inch 1U Rack Mount. I upgraded the included cord to [USB-C] (10 Gbit/s). I also managed to purchase one before the prices increased to their current price gouging ranges.

My primary M1 rig has the following WD drives growing at ~14-30TBs or so:

  • 8x Elements 14TB
  • 2x EasyStore 14TB
  • 2x EasyStore 16TB
  • 3x Elements 5TB
  • 3x Passport Edge 500GB

The smaller drives (less than 10TB) are still packed with solo plots. I’m ~90% pooling vs. remaining plots will remain solo ones. I adjusted my rigs per your guidance to 80min delay; it works well with the new SSD enclosures w/o any disconnecting issues like I had w/ other models. Till the updated GUI releases allowing for faster plotting w/o using the CLI; unless you know of a good crash course I can take?

Shipping may be slower, but it’s cheaper to buy the Acasis enclosures direct

Acasis has a Thunderbolt 3 enclosure that looks very similar to the USB4/T3 enclosure, it’s a bit cheaper, but I got one and it runs around 10ºC hotter than the USB4/T3 enclosure.

Wow, that’s a pricey hub. A lot of farmers are using the Acasis/Sabrent hub. It draws around 16w with 16 3.5" drives attached.

I try to avoid the CLI