Solved: Error performing operation chia plotnft claim

Hello, I’ve been solo farming the new plotnft and before joining a pool, it is suggested to claim your rewards after winning a block.

I have some trouble understanding how to claim the rewards in the CLI. Not sure what -i, --id INTEGER ID is or where can be located.

(venv) ~/chia-blockchain$ chia plotnft claim -h
Usage: chia plotnft claim [OPTIONS]

-i, --id INTEGER ID of the wallet to use [required]
-f, --fingerprint INTEGER Set the fingerprint to specify which wallet
to use

-wp, --wallet-rpc-port INTEGER Set the port where the Wallet is hosting the
RPC interface. See the rpc_port under wallet
in config.yaml

-h, --help Show this message and exit.

Not sure what to add in the required INTEGER. So I tried using the wallet fingerprint number (8 digit)

(venv)~/chia-blockchain$ chia plotnft claim -i (fingerprint)
Choose wallet key:

  1. (fingerprint)
  2. (another fingerprint)
    Enter a number to pick or q to quit: 1

Will claim rewards for wallet ID: (fingerprint).
Error performing operation on Plot NFT -f (fingerprint) wallet id: (fingerprint): {‘error’: ‘(fingerprint)’, ‘success’: False}

Running 1.2.3 version in Ubuntu server

-i, --id INTEGER ID of the wallet to use [required] can be located using chia plotnft show where it says Wallet id 2: the result is 2.

So by running the following command, it should be able to claim the rewards:
(venv)~/chia-blockchain$ chia plotnft claim -i 2