[Solved] Multiple Harvesters with one full node issue. Please Help!

Hi guys,

First time poster! and I’m using Windows Operating System.
I have been successful with setting up this multiple harvesters connection to my full node until recently.
A bit of history, I recently moved my OS ssd to a new, bigger ssd and then i noticed that my chia v1.2.11 failed to load with status “not connected”. So, I read that upgrading to newest version might help and here I am with v1.3.1 and it fixed the “connection” issue.
Next, I started to link my harvesters to my full node using the official guide: Farming on many machines · Chia-Network/chia-blockchain Wiki · GitHub, but, it still does not show up.
I reinstalled the chia by following these steps:

  1. backing up the blockchain_v2_mainnet.sqlite and blockchain_wallet_v2_mainnet_1585755203.sqlite and wallet_peers.data
  2. uninstall chia blockchain from Control panel
  3. delete “.chia”, “.chia_keys” in the C:\Users{user}
  4. delete “Chia Blockchain” in the C:\Users{user}\AppData\Roaming
  5. double click on the chia 1.3.1 installer
  6. paste back in those 3 files above

After all of those steps are done, i repeat the linking process by following these steps:

  1. make sure port 8447 in my main node is opened
  2. ping my main node ip address and port from my harvester and it looks fine
  3. copying the new “ca” folder from my main node to harvesters
  4. run the "chia init -c “{parent ca directory}” and then run the “chia start harvester -r”. But, it still does not show up in my main node.
  5. add in my “main_node ip address” to the harvester’s config file
    I switch on the debug mode in the harvester and managed to find these lines:
2022-03-27T17:17:58.081 harvester harvester_server        : DEBUG    Connecting: wss://{main_node_ip}:8447/ws, Peer info: {'host': '{main_node_ip}', 'port': 8447}
2022-03-27T17:17:58.084 harvester harvester_server        : INFO     Cannot connect to host {main_node_ip}:8447 ssl:True [SSLCertVerificationError: (1, '[SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed: certificate signature failure (_ssl.c:1129)')]
2022-03-27T17:18:01.085 harvester harvester               : INFO     Reconnecting to peer {'host': '{main_node_ip}', 'port': 8447}.

What I have tried to fix this issue:

  • upgrading the python version (???) → does not work
  • downgrading back to chia 1.2.11 → also having the same issue now

Any help will be appreciated!
Thanks in advance.

As the harvester shows INFO about a
…certificate signature failure

I would expect something going wrong in that department.

Are you sure you copied the CA folder coupled to your new installation?
I’m not a windows user but think I remember some topic about 1.3 using different paths on installation.

Can’t find the topic so maybe I’m wrong there.

Whats the output of chia init -c <temp_ca_folder>?

Hi xkredr59,

Thanks for your reply.
Yes, I have already made sure the CA folder is from the new installation. (tried it at least 3 times re-install)
The output of the “chia init -c <temp_ca_folder>” is:

Deleting your OLD CA in C:\Users\{user}\.chia\mainnet\config\ssl\ca
Copying your CA from E:\ to C:\Users\{user}\.chia\mainnet\config\ssl\ca
Can't find private CA, creating a new one in C:\Users\{user}\.chia\mainnet to generate TLS certificates

I have tried to look at this issue in many different angles and I finally decided to reach out to others in this forum to help me out. :slight_smile:
I really appreciate your reply.

Using Linux had something similar and it was permissions on the ca files on the main node that was not allowing you to copy and paste all the certs to the temp location. It was set to root user read only i think.

I don’t know how windows does it,.

Hi Chelle,

Thanks for your reply.
I have tried to set it to not have “read only” and it still failed.

Oh wow, i just realized my stupid mistake after looking at this youtube video: Chia farming on multiple systems - introduction to harvesters - YouTube.
I actually did the “chia init -c” on the parent folder of the CA folder.
It should be including the CA folder itself such as /CA and the issue of “Can’t find private CA, creating a new one in …” will not show up again.
Thanks xkredr59 and Chelle for your reply. :smiley:


As in copy the CA from your farmer node and put it into like c:\files\ca

C:\Users\rb653504\Appdata\Local\chia-blockchain\app-1.3.254\resources\app.asar.unpacked\daemon> .\chia.exe init -c c:\files\ca\

Sure, but you would think that when you run init -c path, it would return some error, when it cannot find those certs. Otherwise, it looks like everything is good, but nothing works.

Also, it would be nice to have ‘chia init --show’ that could be run on both farmer and harvester to show some cert ids, to make sure that both sides see the same thing.

Just recently had a similar issue with the sudden disappearance of my harvesters, turns out that it was a windows firewall problem related to public and private network access, and upon launching chia GUI after update from 1.2.11 > 1.3.0, there were pop-up windows referencing network access and I ignorantly checked the wrong box. After re-tracing my steps, corrected the issue and now harvesters are connected and active once again. Always learning am I.