*SOLVED* Space Pool no partials being found

Good morning everyone. I have been having an issue with Chia for months now. I upgraded to a new machine for my farmer and haven’t been able to get my harvesters back online. I was able to update the client on all of my harvesters last night and get them back online, and my farmer was v1.6.1, but was having issues with “WARNING Fee estimator error”. I upgraded the farmer to 1.6.3 this morning, and now the log is just reporting “WARNING Time for header validate: 0.01796” which is harmless from what I read. The farmer sees all of the plots and is passing filters, but after hours, I still have 0 partials/points in the pool menu and Space Pool is reporting that I have at least one outdated client. My harvesters are on Chia v1.6.2 and v1.6.3 currently. Any ideas? Thanks in advance!

if you have issues for months. it is most likely related to your plots, not Chia versions.

incorrect farmer key?

plotted for wrong address?

if you have no partials, you have no plots.

I still run v1.6.1, and never had issues with partials

1 Like

Yes, try to run your farm all on 1 release, not on different releases.

Also maybe try not running releases that are not really ready yet. ( afaik .6.3 falls into this category )

1 Like

Thanks for the replies. I have been running these plots ever since they released pool capable plots and they were working fine until I switched to the new farmer PC. I will update all to the same release and see if that helps.

1 Like

It may not but it that is advised from chia " official " so certainly needs to be a first step before looking further.

So I changed the farmer log file to INFO, and this is what I get:

“0 plots were eligible for farming a72396b27b… Found 0 proofs. Time: 0.00000 s. Total 0 plots”

I have 153TiB (over 1500 plots), and I have gotten 0 plots eligible and total 0 plots with no change for about 20 minutes now. The GUI does see the plots and says that plots are passing the filter though?

Ok, pls describe your setup?
1 main node plus harvesters or what?

Did you firstly put everything on the same release?
Preferably .6.2 as that is the last stable release ( afaik ).

Because if were talking about 1 box passing filters in the gui but the logs on that box saying otherwise, htf does that happen, it doesnt make sense.

To clarify, this setup was working until November when I upgraded my PC that I use as my farmer. I have two harvesters running Ubuntu server, and a farmer now running Win11 (the old farmer was Win10). Everything was working well and I was using Space Pool previously. When I upgraded the farmer PC, I installed a fresh HD, OS, Chia client etc. I imported my wallet via the passphrase into the new Chia client, then copied my CA folder over to the harvesters, ran the “chia init -c ca” command, started the harvester back up, and although the farmer could see the plots, it wouldn’t ever find any proofs/partials. At this point, I upgraded Chia to the latest version on both harvesters and the farmer, reinstalled the CA folder on both harvesters, rebooted both harvesters, etc. The farmer GUI reports finding plots that pass the filter, but never finds any proofs/partials. The log just says “0 plots were eligible for farming a72396b27b… Found 0 proofs. Time: 0.00000 s. Total 0 plots” over and over again without the number of plots ever changing from zero. If I do a plots check on the harvesters, it says that it “has a farmer public key that is not in the farmer’s pk list”, but I read online that this is normal for harvester only machines.

Disregard on the “0 plots were eligible for farming a72396b27b… Found 0 proofs. Time: 0.00000 s. Total 0 plots". That is the farmer looking for a local drive that has been removed. Looking at the debug log on the harvesters show that plots are eligible for farming and have a total of 838 plots, but they still never find any proofs.

Okay, I figured it out with the help of someone on Discord. I no longer could see my old Space Pool plotNFT under the pooling tab in the farmer GUI on the new farmer, so I created a new one when I setup the new farmer. This additional plotNFT appears to be the issue (or a symptom of the issue) for some reason. Someone on Discord said to close Chia on the farmer, set “connect_to_unknown_peers” to false in the config.yaml, and then delete the SQL database file in the mainnet/wallet/db directory. I did this, then restarted the farmer Chia client, let it resync (a few minutes), and then my old plotNFT appeared in the pooling tab and I instantly started finding proofs! I then closed Chia, set “connect_to_unknown_peers” back to true, and restarted the farmer client. It took a few minutes to find peers after this, but I am back up and farming. Thank you to everyone who helped and offered suggestions!


Hmmm, ok , glad your all good again.
But from my perspective ( yours is yours and just as valid )

Nonsense !

What happened is you created a new nft, so your node scanned the chain and updated data.

Next time just delete wallet db, let it sync ( 120s prob, ) same outcome, no extra nft!


1 Like

hmm … i can’t find such an option in my config

On my Win11 install with Chia 1.6.3, it is located at:
C:\Users\USERNAME\ .chia\mainnet\config\config.yaml

It is line# 356:
connect_to_unknown_peers: true

1 Like

why does anybody use non-official release?

If you’re referencing 1.6.3, that is the official release. I downloaded it directly off of Chia’s website.

I cant see it on the download page, unless its the dev build, which you probably shouldnt be using

Ah, I lied to you, I just realized I was wrong about the Chia version on my farmer. 1.6.3 is the build that the harvesters updated to when I ran the command to get the latest update on Ubuntu server. I actually downloaded 1.6.2 from the Chia website, and that is what the farmer is running.

1 Like