SSD activity to 100% and writing speed to 0 while plotting

Hi everyone, newbie question here !

I’m trying to plot a few K32 on a gaming computer and the ssd I’m trying to plot on acts really weird…

First, I tried with the ssd connected with USB and everything was working perfectly but damn it was so slow !
I decided to connect it via SATA (speed supposed to increase by 10x) and power it.
When I started a new plot (temporary folder on the SSD), everything worked fine for 2 min, then the “activity” of the SSD went to 100% and the writing speed dropped to 0 mb/s.

After that, the PC froze and I had to crash it…
I tried several times with default settings and custom ones for the plotting but everything ended up the same way !

Has anyone faced this issue ? I would be glad if anyone could help me :slight_smile:
Thanks !

Hardware infos :

  • SSD : Samsung 870 QVO
  • 16gb of Ram
  • Ryzen 24 cores


yes, this is a “typical” plotting-stuck. For me most time i relates to some hardware issue…here some points i figured out for my machines:

  • defectiv ram
  • to much oc on cpu/ram
  • defective sata-cable
  • worn out SSD
  • old sata-drivers

Hi ! Thanks for the answer

Both the SSD and the Sata cable are brand new and the problem is still here with the default settings for ram and cpu…
I’ll investigate on the ideas you gave here and I’ll keep you posted

I hope it’s the drivers :crossed_fingers: haha

How many is a few, 3?
You could be limited by your ram if your trying too many at once.
Maybe start with 4 and see if it runs ok

For us to better assist you, pls add # of plots started, how, and w/what parameters. From what u wrote here is what I see.

1st, the 870 QVO is a terrible choice for Chia plotting. It’s not made for this type of work, rather for someone on the web, or email,or who downloads a file here and there. It’s write cache is small, and when exhausted, it reverts to ~150MB/s speed, worse than many hard drives, forget typical (good) SSDs.

2nd, USB (if ur referring to USB 3) is not 10x slower than SATA. In fact they are very close in effective speed and therefore for their plotting ability. Of course, plotting ability again depends on the quality of your SSD.

As to freezing, we need more from you re: plotting parameters and system hardware.

Hi ! Thank you all for your answers.

So I checked and the SATA drivers are up to date, so that’s not the problem

All I said in my first post is for one K32 Plot (no parallel) with the defaults settings of the GUI.

  • 3390 MiB Ram
  • 2 therads
  • 128 buckets
  • Bitfield activated

I tried with bigger plots, more threads and more Ram at first but Seeing it was not working, I decreased them until I reached the defaults settings.

When I said 10x, it’s because I only get 45 Mo/s with usb and more than 460 Mo/s with SATA (it’s what’s displayed on the specs)

I understand that the 870 QVO is a bad choice in term of life Time but, it is supposed to work fine before it’s prematured death no ?

I was wrong in my first message, the pc hardware is :

  • AMD Rysen 9 3900X 12 core processor (24 threads)
  • 16 Gb ram

Hope this give all the infos you asked.


Have you tried testing your m.2 is working properly?
I’ve no idea what software will check that.
May be worth testing your ram also, but that takes quite a while.

I was reading this thread, seems similar problem, possibly it is the m.2.

I try again. The 870 QVO is not for Chia plotting. Full stop. Don’t take my word, here is a review addressing the 870 QVO write capability:

"To more appropriately test the QLC-based SSDs we modified our consumer testing methodology to better reflect how these drives are designed to work out in the field. Compared to MLC or even TLC products, QLC-based SSDs have a very small continuous write ability. QLC SSDs mitigate this through adaptive SLC caching, but the short version of the story is after writing 10-15GB of data to the SSD at once, write speeds will drop from 1,500MB/s down to 100MB/s."

Aside from that, I (foolishly) bought a 2tb 870 QVO and tried it. Then returned it. Remember USB 2 speeds you may get are ~20-40MB/s, so it’s better than that, but barely. I now think of them as a thumb drive stuck in a SATA ssd case. And then they need to write 101GB plot files. Good luck.

A single plot writes about 1.6 TB while plotting to your temp drive. So the situation in more worse than 101GB.