Stale Partials 29% windows

After I had to resync the farmer, I have 29% Stale Partials

My farm is an older HP laptop with an i5-4310M @2.7GHz and 8GB RAM and 256GB SSD.
As operating system I use Windows 10 Pro
I have a total of 1006 plots (99,778 TiP):
Connected with SATA to USB adapters and USB HUBs (67TB).
NAS (33TB) via 1GBit network

Since I had to resynchronize the db, I now have the problem that 239 of 823 partials arrive too late in the pool. (24h)
The times are completely bad, but I do not know why.

The farm also started sending many wrong partials before the crash (=> reason for resynchronization).

I have already turned off many things that are not needed on Windows.
(Updates only manually, antivirus off, Auto Start everything off …)
What other tips do you have?

How could I fix the problem?

You could (temporarily) disconnect the NAS share to see if the invalid/stale partials are caused there.
Sata/USB adapters don’t introduce much delay, NAS shares are more likely to do this.

Your CPU and Memory/SSD should be up to the (chia-)task.

What NAS do you have, is it capable of docker, then installing chia as a remote harvester should improve delay times by a lot.

2 Likes

Are USB and/or NAS drives perhaps going to sleep mode and spinning down after x time?
On a laptop default settings are usually to enter sleep after … min.
On the NAS depending on brand/type also I think.

2 Likes

I have a Synology DS918+ and a Synology DS1512+. Now I have configured both NAS with the official Docker as Havarester.

On the laptop I have checked all the settings. Power saving mode and hibernation of the HDDs are disabled.

After 3h the error rate has dropped to 17% on the last 100 pieces. However, the main source of errors still comes from the laptop, which is only connected to the USB.


But the time looks much better

Looks much better indeed.
What is this monitoring tool you are using, don’t know it but it looks nice?
You did see it’s only reporting on the plots on USB connected disks now? Disavantage of the docker harvester on Synology is that reporting/monitoring is hard to do. But Space Pool will tell you the overall results. Space Pool’s partials tab will show two harvesters now, so it’s easy to see where stale/invalid partials come from (but hopefully not;-)

I’m not sure if this also influences USB harddrives but did you also disable USB Selective Suspend?
There is much more on this subjest on Google but this site explains pretty well I think.
https://helpdeskgeek.com/windows-10/what-is-usb-selective-suspend-on-windows-10-and-how-to-disable-it/

2 Likes

Double check your network adapter power settings. I had a similar issue with stales (despite “performance” profile was set). The network adapter may have its own “economy” or “performance” modes.

If nothing else works the final solution is generally to just run flexfarmer. I know it’s crazy but the last person on this forum who had an issue he couldn’t solve in 50 replies gave up and just did it and it worked. It solves almost every case that comes up.

We solved a lot of the bugs with the OG farmer and improved a lot of things. Most of the issues farmers experience are caused by those bugs.

@Chris22
Is flexfarmer compatible with remote harvesters? From your setup page I would guess not but I can easily have missed something;-)
https://www.flexpool.io/get-started/xch/flexfarmer/?primaryServer=xch-de.flexpool.io

Each flexfarmer connects to flexpool independently. You can give them different names so that you can see each on your page of the pool. They don’t talk to each other only to the pool servers

Thanks. A remote harvester would turn into a separate flexfarmer ‘node’. And there is a docker version for NAS boxes, overlooked that before…
Still, do you need a separate private farmer key for each ‘node’ so different keys/mnemonics?

Look at the raw log file for WARNING lines which will show you the patch to affected plots when you hit a slowdown. If the path is pointing to USB drive then likely it’s spinning down and it takes few seconds to have it spin back up which needs to be addressed.

I also had problems with Synology NAS not keeping the drives spinning even though it is set to never put them to sleep so had to create a script to keep them spinning from the harvester.

If each plot was made under the same nft you can use the same config file for each setup but change the worker names so they don’t overlap.

No. Flexfarmer doesn’t use the private key except that you need it to get your public key to give to flexfarmer config

hello, my plots are og, but on the site I did not find how to include them in your pool, help me

We’re a nft pool so nft only.

Thanks for all the tips.
I wanted to stay with the official client and not switch to Flexfarmer.
I’m happy to share my process with you, maybe it will help one or the other.

The tool I use I got from GitHub - kubec/chia-log-analyzer.


The following points are true and I have corrected them:

1. NAS instead of network access as Havarester Chia farming - Using Synology NAS as a remote harvester - YouTube
2. ALL USB disk in the device manager turned off the power saving mode.
3. My switch (HP 2530) was configured incorrectly (first time use and had to reset the password).
4. Network adapter (laptop) checked, but true set correctly.
5. Chia DB V1 replaced by V2.

Here I have after the pull request dbv2 upgrade - alternative approach by neurosis69 · Pull Request #10116 · Chia-Network/chia-blockchain · GitHub experimentally on a test PC. For this from chia.net under Downloads the Beta Version 1.2.12261 (WIN) downloaded and executed via the command line .\chia.exe db upgrade.

  • In my test PC / plotter PC it went 120.28min. The synchronization goes after only a short time check brisker progress. (Is but only a gut feeling and is not measured)

After check and the first valid Partial I decided to use also on the active laptop.

  • On my active setup I decided to replace the database again with .\chia.exe db upgrade. The interesting thing here is that the time for this was only 58.27 min. Here the speed is probably not directly dependent on the performance of the PC.

The database is currently shrunk from about 42GB to 25GB and in my opinion faster. But attention BETA SOFTWARE.


The effort can be seen:

While writing this post I see that my laptop has sent an invalid partials.

Compared to almost 30% late to 1% wrong, it is already a big progress.

I hope I can also help with these steps other people who have the same problem.

1 Like

Thanks for this detailed feedback :+1:
Step 5 in your approach looks very interesting! It looks a very recent development but already noticed by Chia dev’s. Hopefully they can bring it into the mainstream client.
Or is it already in the Beta and the reason you switched to the Beta version? Couldn’t find release notes for the Beta…

Would be interesting to hear your experience with this some more, could you let us know in a few days?

It was pure coincidence that I came across it in the pull request. The description of the beta builds:

Latest Beta
Note: Beta builds are built on every merge to main and may contain bugs or other issues that are not present in tagged releases*

For the beta there is never a release notes.

After that, I just started the experiment and tested whether this feature already works.
As far as I know it should flow in the future also in the new release. If it will be implemented in 1.3, I don’t know.

With the feedback it could be difficult for me in the next time, since I am surely two weeks in the service. But I will do my best to check it remotely.

A few days, a few weeks, all is perfectly fine of course :+1:
Take care ‘in the service’, hope you have a good time (some of it at least;-)