STDERR: Fatal Error

Good morning all. I’ve bought a Dell R620 to plot with and keep geting this error in Bladebit disk (ChiaGUI) as soon as the plot starts.
STDERR: Failed to obtain temp paths block size from t1: 'D:' or D:\ t2 ‘(null)’.

I have tried different temp paths/ drives but get the same error. MM will plot to these temp paths so I don’t know why Bladebit will not? Any advice will be gratefully received.

Good morning,

You didn’t provide your system specs CPU, memory, and type of temo drive (nvme, ssd etc)

2 x Xeon E5-2665
OS on 600GB 10k SAS HDD
6 x 600GB 10k SAS HDD RAID 0 for temp1
128GB RAM Disk for temp2

Hope I haven’t forgot anything

Here is a string that I had saved in a note file
bladebit -f xxxxxxx -c yyyyyyyy --threads 31 -n 1 diskplot -b 128 --cache 110G -t1 f:\ -t2 f:\ e:\

Also you didn’t say if you’re using Windows or Linux. The above is from a windows plotter.

Thanks so much, I really appreciate your help.
My computer skills are not good but I have a lot of raw determination.
I’m assuming that I need to download a standalone CLI version of Bladebit for this string?
If you have this string saved, do you have the same system as me?
I’m using Windows server 2016.
Not sure what -f and -c parameters are, so don’t know what xxxxxx and yyyyyy represent?
Thanks again.

OK, so I’ve worked this bit out I think:
-f <farmer_public_key> -c <pool_contract_address>

Does -n = number of plots?

What is -b parameter please?

C:\bladebit201>.\bladebit -h

Some reading info

C:\bladebit201>bladebit help diskplot

Thanks buddy, really appreciate the help!
The kids are keeping me V busy at the moment, so will probably have to look at it tomorrow now and no doubt get back to you with Q’s.
Best rgds,

Well I got a chance to try this and got the same error.

Bladebit Chia Plotter
Version : 2.0.1
Git Commit : 9fac46aff0476e829d476412de18497a3a2f7ed8
Compiled With: msvc 19.29.30146

[Global Plotting Config]
Will create 1 plots.
Thread count : 31
Warm start enabled : false
NUMA disabled : false
CPU affinity disabled : false
Farmer public key : b2b2b675f0e198730191b07008fe11ef7d9dde42d91dc0e81749efd69a6afbc04c6e2075e9854608d1ab7efde494d9de
Pool contract address : xch1f973flpa9wmec373zngjujqvgwe97wt4rrgydgnu7sgwy9hc8huqj9p84f
Output path : e:\

Fatal Error:
Failed to obtain temp paths block size from t1: 'd:' or f:\ t2: ‘(null)’.


Any ideas?

BB Disk is bug ridden, and performance varies drastically across different CPU architectures. The best is to just give up and use MM CPU plotter. On my two boxes (e5-2600 v2 and i9-10900) it was a real struggle to get it to run. However, when I finally managed to run it, it was much slower than MM (in the range of 50%-100% slower).

Also, MM was recently updated and is about 10% faster (also depends on CPU architecture), further making BB Disk rather a worthless plotter at the moment (again, potentially not on every architecture, as some people reported success with it).

The shiny comparison of BB Disk to MM plotter was done without having Max to provide his feedback how to tune it, what makes such comparison rather a sham. The support for it on Github is next to nothing, where the main developer blames everything but his code. As Chia stated, everything that they release is a sample code, and from time to time it is just poorly written sample code.

You can download the latest MM from here - Releases · MMX-World/mmx-plotter · GitHub. Although, when I have just tried to download it, Microsoft Defender stepped in and I needed to tell it to bug off (keep the file). This is the official MM download, still they should have contacted MSoft to let them know to have Defender to back off. By the way, I did try to use v1.1.8, and that one was giving me ~10% speed improvement. I have not tried v1.1.9, though.

I have filed a request with MM team to contact MSoft to potentially remove that warning. Although, MSoft is slow to respond (based how they handled my download), so it may take a week or two to have them act on it. MM is one of the most trusted software for Chia (as far as security), so at least I would ignore that warning (especially seeing it happen on my program download).

1 Like

Will this string work for MM also, as I’m having trouble getting BB to work? Thanks.

bladebitv201-mmx -f ffff -p pppp --mmx --threads 22 -n 1 diskplot -b 256 --cache 128G -t1 F:\nvme e:\mmxplots
I downloaded the file and renamed it to keep track

But this is slower than using the new cuda files which are quick!!! And can make compressed files “TODAY”

I think he meant MadMax plotter not MMX :wink:

If you want to use the original madmax plotter for Chia in Windows, you can try this one, comes with a very handy little GUI called plotmanager to plot with, super easy.

I’m having problems with Bladebit as well. if I don’t specify cache it plots without any problems but I get allocation errors when trying to plot with --cache 110 and even during the bladebit memcheck it also gives allocation errors. Using with a -t2 as a ramdisk also fails.

I’ve gone back to MadMax v0.1.5 with a ramdisk and it’s plotting away fine. Similar times as bladebit without the cache but at least my ssd’s are taking less of a hit. Since I have a 3090 and a 2080ti sitting idle awaiting gpu plotting I have decided not to waste a lot more time looking into it.

Well I finally got it all working. After reloading OS I finally realised that both BB & MM .exe’s contained 0kbs :frowning: so must have been a problem unzipping them.

I just wanted to say a big thanks for everyone’s help/support, especially Drhicom’s!

Now on to the next problem! How to get my plots under 42 mins?

Using Drhicom’s string: bladebit -f xxxxxxx -c yyyyyyyy --threads 31 -n 1 diskplot -b 128 --cache 110G -t1 f:\ -t2 f:\ e:\

-t1 is 128gb RAM disk and -t2 is 3 x 372gb SSD in RAID0. I have 2 x E5-2690 V2s on order to replace the 2 x E5-2665s. Anyone have any experiance with how much difference this will make?

FYI, MM is approximately 15 mins slower using the same setup.

Update. I’ve got the plot time down to 37 mins by lowering the threads to 28, any lower and the time starts to go back up so this seems to be the sweet spot for my setup. I can’t wait to try the 2690 V2s when they turn up!