Stuck Chia in selfpooling

More than a week ago I farmed a block and got .25 Chia, but when I try to claim remaining 1.75 Chia from self pool, I get a message “Cannot claim due to unconfirmed transaction. If this is stuck, delete the unconfirmed transaction.”
I have tried deleting transaction multiple time but whenever I try to claim, I again get the same message.
I am fully synced. I have tried closing the app and restarting, but nothing working.

  • make sure you are really selfpooling (chia plotnft show)
  • delete unconfirm transactions then close the client
  • change your IP address (router restart or vpn)
  • restart client and claim it again

if there is no dustsotrm in progress of course :slight_smile:

1 Like

So I hade a similar issue and it turned out that the client had somehow corrupted the wallet db and gotten stuck.

So I suggets you

  1. Close the client, make sure you either restart your computer or run “chia stop all -d” command line to make sure all chia processes are shut down.

  2. Then go to the chia folder, locate wallet folder (chia/mainnet/wallet) and remove either the entire folder or just everyting in it. DO NOT REMOVE THE “db” folder (chia/mainnet/db) because that will take ages to resync.

  3. Now restrat the client and it will resync the wallet, takes about a minute, then try to claim the rewards again. Dont forget to add a 1 000 mojos as fee so you get through in case there is a dust storm.

2 Likes

Currently not an issue.

Thanks for the suggestions. I tried even 10,000 mojos. There is nothing inside Wallet folder except DB folder.

I just deleted the DB folder. It only took few minutes to sync wallet after this. I was able to release stuck chia. Strangely, it is show in the balance but not in the transactions.

1 Like

thats ok, I was talking about not deleting mainnet/db not mainnet/wallet/db

Glad it worked