Swarm config doesn't do what it's supposed to

Hi,

I am new to swarm and have a littel strugle with my config.

My Setup:

AMD Threadripper 3960x 24 Core
64GB Ram 3200MHZ
4x Firecude 510 SSD 4TB (Plotter 1-4)
1x Samsung Pro 980 1TB (Plotter 5)

This is my config.yaml

>     - name: Plotter1
>         max_plots: 999
>         farmer_public_key:
>         pool_public_key:
>         temporary_directory: J:\Plotter
>         temporary2_directory:
>         destination_directory: O:\
>         size: 32
>         bitfield: true
>         threads: 8
>         buckets: 128
>         memory_buffer: 4000
>         max_concurrent: 6
>         max_concurrent_with_start_early: 7
>         initial_delay_minutes: 0
>         stagger_minutes: 20
>         max_for_phase_1: 2
>         concurrency_start_early_phase: 4
>         concurrency_start_early_phase_delay: 0
>         temporary2_destination_sync: false
>         exclude_final_directory: false
>         skip_full_destinations: true
>         unix_process_priority: 10
>         windows_process_priority: 32
>         enable_cpu_affinity: true
>         cpu_affinity: [ 0, 1, 2, 3, 4, 5, 6, 7 ]
>         
>       - name: Plotter2
>         max_plots: 999
>         farmer_public_key:
>         pool_public_key:
>         temporary_directory: I:\Plotter
>         temporary2_directory:
>         destination_directory: D:\
>         size: 32
>         bitfield: true
>         threads: 8
>         buckets: 128
>         memory_buffer: 4000
>         max_concurrent: 6
>         max_concurrent_with_start_early: 7
>         initial_delay_minutes: 0
>         stagger_minutes: 20
>         max_for_phase_1: 2
>         concurrency_start_early_phase: 4
>         concurrency_start_early_phase_delay: 0
>         temporary2_destination_sync: false
>         exclude_final_directory: false
>         skip_full_destinations: true
>         unix_process_priority: 10
>         windows_process_priority: 32
>         enable_cpu_affinity: true
>         cpu_affinity: [ 8, 9, 10, 11, 12, 13, 14, 15 ]
>         
>       - name: Plotter3
>         max_plots: 999
>         farmer_public_key:
>         pool_public_key:
>         temporary_directory: H:\Plotter
>         temporary2_directory:
>         destination_directory: D:\
>         size: 32
>         bitfield: true
>         threads: 8
>         buckets: 128
>         memory_buffer: 4000
>         max_concurrent: 6
>         max_concurrent_with_start_early: 7
>         initial_delay_minutes: 0
>         stagger_minutes: 20
>         max_for_phase_1: 2
>         concurrency_start_early_phase: 4
>         concurrency_start_early_phase_delay: 0
>         temporary2_destination_sync: false
>         exclude_final_directory: false
>         skip_full_destinations: true
>         unix_process_priority: 10
>         windows_process_priority: 32
>         enable_cpu_affinity: true
>         cpu_affinity: [ 16, 17, 18, 19, 20, 21, 22, 23 ]
> 
>       - name: Plotter4
>         max_plots: 999
>         farmer_public_key:
>         pool_public_key:
>         temporary_directory: F:\Plotter
>         temporary2_directory:
>         destination_directory: K:\
>         size: 32
>         bitfield: true
>         threads: 8
>         buckets: 128
>         memory_buffer: 4000
>         max_concurrent: 6
>         max_concurrent_with_start_early: 7
>         initial_delay_minutes: 0
>         stagger_minutes: 20
>         max_for_phase_1: 2
>         concurrency_start_early_phase: 4
>         concurrency_start_early_phase_delay: 0
>         temporary2_destination_sync: false
>         exclude_final_directory: false
>         skip_full_destinations: true
>         unix_process_priority: 10
>         windows_process_priority: 32
>         enable_cpu_affinity: true
>         cpu_affinity: [ 24, 25, 26, 27, 28, 29 , 30, 31 ]
>         
>       - name: Plotter5
>         max_plots: 999
>         farmer_public_key:
>         pool_public_key:
>         temporary_directory: E:\Plotter
>         temporary2_directory:
>         destination_directory: O:\
>         size: 32
>         bitfield: true
>         threads: 6
>         buckets: 128
>         memory_buffer: 4000
>         max_concurrent: 3
>         max_concurrent_with_start_early: 7
>         initial_delay_minutes: 0
>         stagger_minutes: 20
>         max_for_phase_1: 2
>         concurrency_start_early_phase: 4
>         concurrency_start_early_phase_delay: 0
>         temporary2_destination_sync: false
>         exclude_final_directory: false
>         skip_full_destinations: true
>         unix_process_priority: 10
>         windows_process_priority: 32
>         enable_cpu_affinity: true
>         cpu_affinity: [ 32, 33, 34, 35, 36, 37 ]

And this is what Swarm accutaly does.

He is just starting 1 Plott in Phase 1 the next Plott starts when Phase 1 is finished.
Plotting on Plotter 4+5 doesn´t start.

But Swarm shut fire up two Plotts with a delay of 20min for Phase 1 on all Plotters. With a max of 6 concurrent Plotts per SSD.

Where is my mistake ? Maybe one of you can help me with that problem.

Thanks a lot !!!

Edit:
Ohhhhh man, I am that stupid. I ignored the global settings. I am SORRY!!!

But maybe some of you have some tips for optimization?

1 Like

I was going to ask about your global settings. But it looks like you found it yourself.