Swar's latest version error

One benefit of needing to rebuild my plotting systems last night was that I took the opportunity to go to the new version of Swar’s Plot Manager. But on one system, I have had an error in the manager viewer twice since last night. Any thoughts on the cause?

My only thought is that last night I did forget to remove the sleep setting from these systems and they both wen to sleep. I woke them both up and plots continued with no problem. Since then, one system has given this error twice. The other system, no errors. It doesn’t affect the plots, just crashes the viewer.

1 Like

Did you also update CHIA to the new version?

You will need to change the location of chia.exe in the file. (from 1.1.5 to 1.1.6 in the path)

Also the newer version of swar has some more settings in the config file…

I deleted my old yaml and created a new one based on the default which is included with new package, that is what fixed it for me.

1 Like

Everything is new. I had to reload the entire system. So Chia version 1.1.6 and new Swar’s. New config files for all. The Chia location is correct, everything is running fine, just a viewer error every now and then.

I had the same, all new + reboot seems to have fixed it for me.

However sometimes view seems to restart due to stalling.

Also I am testing out your Temp2 setup with a sata SSD. On my slow system it seems to reduce the time from 16 hours to 15 hours. The view does show the temp2 drive and the percentages used, but it doesn’t show which plots are using temp2.

Lastly, I have added 2 destinations, but it seems to pick the local PC one over the network location which is entered as first option.

It will take some more time to confirm this behavior though.

1 Like

Had the same error, I did the following:

  • Created a fresh copy of the config file with my settings from the initial YAML file
  • Deleted all the cache in the temp destination
  • Completely uninstalled python (run as admin)
  • Installed Chia Net over my old installation (did not uninstall beforehand)


Installed latest python (run as admin) with install to PATH option in the setup


Started Chia and wait for Sync
Started command line as admin and then started Swar Manager

Hope this helps

1 Like

There are traceback logs for a reason. Very last line says access denied, which is due to insufficient privileges. Running command line as admin(sudo for Linux) should fix this.

If it was truly a permissions issue, it wouldn’t run at all. Starting it right back up, it runs fine and has been for the last 5 hours.

This is a fresh load of all software involved, even the OS. Not an upgrade.

I think this was just a leftover issue from the sleep mode event. It seems to be fine now.

1 Like