The remote computer refused the network connection

Suffered a power loss while farming and cannot reconnect to full node. Tried uninstalling Chia and installing newest version 1.2.11 and it just spins.

My blockchain_v1_mainnet.sqlite database file is 38GB in size so my guess is something is being rebuilt and I need to wait for several hours for it to error out or something is corrupt and needs rebuilt.

Any suggestions?

Tons of these errors
2021-12-18T19:17:11.972 wallet wallet : INFO Reconnecting to peer {‘host’: ‘’, ‘port’: 8444}
2021-12-18T19:17:12.248 farmer farmer : INFO Reconnecting to peer {‘host’: ‘’, ‘port’: 8444}
2021-12-18T19:17:12.978 wallet wallet_server : INFO Cannot connect to host ssl:<ssl.SSLContext object at 0x0000022B9389B340> [The remote computer refused the network connection]

Also, firewall is opened up on 8444 and I was up and running fine yesterday. netstat -aon does not show port 8444 listening so i’m at a loss

The first thing to do is to check whether you still have room on that drive. Potentially, it is full, thus neither db is operational.

The second is to eventually kill your wallet db (about 8 GB). I think that rebuilding it takes “just” few hours. Although, when you kill it, I think that all those spinners should be gone, as those reflect mostly blockchain db.

If that doesn’t work, then your main db is screwed. Two-three days to fully sync, or you can download it from and be up-and-running in an hour or so. Although, there are some concerns whether that db is being poisoned or not.


Drive isn’t full. Renamed config.yaml to .old and that didn’t resolve it. Renamed the blockchain_v1_mainnet.sqlite to .old and it worked but I am now currently rebuilding the entire chain, who knows how long that will take :stuck_out_tongue:
Currently at 64/1,299,363 so I guess without knowing a way to fix a corrupted .sqlite file (since I didn’t back it up…) this is just how it is

Thanks for the response, btw!

Once every two weeks, I shut dowm my farmer GUI and reboot and copy the .chia folder to a backup USB drive (CYA) so far I’m good and haven’t needed it. But always make backups.

1 Like

I went through a terrible occurrence when the dust storm hit us. The dbase rebuild can take days or weeks (which is just another way of saying the programming sucks!) What does help is lowering your peers. Lower it to 20 tops, for me 10 works perfect as you get good quality peers to rebuild in 36 hours. I learned the hard way. Good luck.

Lastly, set up your backup to run every day so if you get corrupted, you just bring up the files and take off in an hour or less vs. the pain you will go through,

Looks like I’m not the only one. Been rebuilding for 48 hours and am still not done 976,224/1,235,894

As @Lsherring stated, you just hit a bad time to be syncing, as we have another dust storm going on that basically screws a lot of nodes (i.e., your sync time).

With that said, he also suggested dropping the peer count to 10. Did you follow that? I would also for time being suppress the log level down to ERROR.

Could you take a snapshot of your Connections section on the Full Node tab and post it here?

They will probably blame the version you are on and to go to .11 Sad, but I have lived this nightmare.

@Jacek did we have another dust storm? When? Any details?

Yeah, two waves. Either your rig didn’t have any problems (that would be my guess), or you were stuck in v1.2.11 upgrade.

1 Like