Trying to validate a plot

Im getting a note that a bunch of my plots failed to open and are considered invalid.
I tried to check the plot using the CLI but I don’t think it’s working properly. Any idea how to debug what is being displayed below?

[root@hp5 ~]# /root/chia-blockchain/venv/bin/chia plots check -g /Plot2/plot-k32-2021-05-01-20-29-bfb2c4dd1f7c494fece7863ee13605c5f9779af8426237ac0f721e867581e812.plot
2021-05-07T06:02:37.971  chia.plotting.check_plots        : INFO     Loading plots in config.yaml using plot_tools loading code

2021-05-07T06:02:38.056  chia.plotting.plot_tools         : INFO     Searching directories ['/root/Chia', '/home/Chia', '/Plot4']
2021-05-07T06:02:38.056  chia.plotting.plot_tools         : WARNING  Directory: /root/Chia does not exist.
2021-05-07T06:02:38.169  chia.plotting.plot_tools         : INFO     Not checking subdirectory /Plot4/@Recycle, subdirectories not added by default
2021-05-07T06:02:38.180  chia.plotting.plot_tools         : INFO     Not checking subdirectory /Plot4/@Recently-Snapshot, subdirectories not added by default
2021-05-07T06:02:38.207  chia.plotting.plot_tools         : INFO     Only loading plots that contain "/Plot2/plot-k32-2021-05-01-20-29-bfb2c4dd1f7c494fece7863ee13605c5f9779af8426237ac0f721e867581e812.plot" in the file or directory name
2021-05-07T06:02:38.269  chia.plotting.plot_tools         : INFO     Loaded a total of 0 plots of size 0.0 TiB, in 0.27420639991760254 seconds
2021-05-07T06:02:38.270  chia.plotting.check_plots        : INFO
2021-05-07T06:02:38.270  chia.plotting.check_plots        : INFO
2021-05-07T06:02:38.271  chia.plotting.check_plots        : INFO     Summary
2021-05-07T06:02:38.271  chia.plotting.check_plots        : INFO     Found 0 valid plots, total size 0.00000 TiB

You don’t have /Plot2 in your search directories.


Thanks, I added it and now it’s testing as valid, although the gui still shows it as invalid.

Was it being copied? It’ll show as invalid during a file copy, for example. That’s why I try to rename plots when copying them.

1 Like

It probably was moved at some point, but once it’s in the list on the GUI it seems to stay there forever. I don’t know how to clear the list from the GUI. I did run through the chia plot validation on the command line successfully for all the ones listed in the GUI, but even after bouncing the GUI they are still there.

1 Like

Oh yeah. I usually close and re-open the GUI to clean out old false "invalid plot"s from when I was copying *.plot files around.

I suggest reporting that on the github issue page, I agree, there should be a way to clear that out!

1 Like

Im assuming when you close the GUI, you stop farming, since the farmer and full node are both in the GUI.
Eventually, I would love to figure out how to break out the full-node, the farmer and the harvesters to different hosts, but right now they are all on the same windows box. Ive tried several times to break them up, but it doesn’t work for me. Ive heard others have success with this, but the instructions seem to work but I get no plots passing filters, and it doesn’t show the proper plot count. So, communication between the hosts isn’t working as expected.

Well yeah, but only briefly. In my experience you sync up again very quickly, because you have almost the complete blockchain.