Tutorial on setting up Ubuntu, LSI 9201-16e HBA Card and an ASUS Z590 motherboard

For those following my journey in Chia, it’s actually been a blast down the road of building out beefier machines than I’m used to at home.

The struggle this morning was getting my eBay-bought LSI 9201-16e HBA card working on Ubuntu 20.04 - I have a 12-disk enclosure sitting next to the machine with these 3x newfangled SFF-8088 mini-SAS cables running between the host plotter and the JBOD.

Anyway ALL of this was new to me so I spent hours figuring it out then a few more hours writing it all up - I hope it helps someone on a similar journey!

https://rkalla.me/linux-ubuntu-asus-z590-lsi-9201-16e-hba-card-and-how-the-hell-you-get-it-all-working-together/

12 Likes

BROO!! Now I want to get “RKALLA IS WORLD’S SMRTEST MAN” tattooed on my arm!! This write up is GOLD! :sunglasses:

Great job man, you just paved the path of the future!

LOL! I’m just happy to get this stuff written down - all of us here are treading into uncommon areas and it’s pretty freaking exciting.

I learned just as much from you bro reading through the forums and giving me confidence to push forward!

1 Like

Really nice of you to say!

Honestly I will have 100% satisfaction if some day, some guy or gal that has never mined chia or dealt with an HBA card before reads that and goes “OHHHHHHhhhhhh ok I get it now.”

Basically what I desperately wanted to find in a forum post myself but had to put in the leg work instead.

2 Likes

Nice work.
I’m glad you did it !
I was thinking in equal setup, with SCSI drives just for plotting.

One HBA card, one breakout cable and 4 SCSI drives of 600Gb each in RAID 0.
That little detail about " IT" flashed card, is very important.

I managed to found one HBA LSI card already flashed.
I think I will go do down that route, instead of destroying Nvme cards for plotting.

Best regards.

Keep us posted on how it performs! That would be a solid array with significant throughput so I imagine it will do well.

Amazingly useful! I have basically a similar setup and less experience and spent literally days trying to troubleshoot this. You have both given me hope and saved me several hours of research. Thank you!

I’ve got to the last step as you but I’m not seeing the drives (I’m seeing the card with the latest firmware - both in Ubuntu and W10). I noticed you are using SATA drives - I’ve got some SAS drives.

My thinking was that the card did the “translation” to SAS - but is that wrong? Maybe I need a different mobo.

My SAS drives aren’t spinning up (or don’t appear to be)

I’ve got some cables coming to connect some SATA drives to test that theory. Although I would like to get the 8 SAS drives working!

Also - I’ve got the BIOS installed on the card - will try wiping that and see if that works.

To answer my own question - others may be interested.

I flashed the card again but this time I erased everything first (in EFI shell)

It now works and I can see the SAS drives.

There was a mismatch between NVDATA default and persistent. They are now the same versions and works as it should.

ohhhh! This is an interesting find, I should add it to the tutorial… how did you erase everything?

Also thank you for the kind words, THIS made my week:

That was my WHOLE GOAL! Yay!

For interest - it now works in Windows 10 fine too.

My previous problem showed up if you know what you’re looking for.

When running SAS2Flash -list it would show NVDATA (default) as a different value to NVDATA (persistent). I think this happens when you update sometimes (or at least it happened to me). The symptoms were that you could see the card with up to date firmware but the drives still wouldn’t be visible (or indeed spin at all).

To get around this I wiped everything by booting into the EFI shell and running sas2flash -o -e 6 and then reinstalling the firmware. I couldn’t clear the bios running this in Ubuntu.

It sounds like the sort of thing which runs the risk of bricking the card - but I have no idea!! It worked for me and that’s all I know.

Described as a “Clean flash (erase everything except manufacturing area)” in the documentation. https://docs.broadcom.com/doc/12355769

I made sure I had the firmware back on the card and successfully showing info in -list command before rebooting.

1 Like

Thank you bro, tutorial updated!