Ubuntu 21.04 installation problem

I’ve been trying to install this on a separate SSD partition of a Windows 10 system (dual boot). The Ubuntu is from a downloaded .iso file. I’ve disabled secure boot on the ASUS motherboard and disabled fast boot in Windows.

The installation with a bootable flash drive appears to go smoothly. I select the normal (full) installation and the third-party software. Have been choosing the BTRFS file system. There’s plenty of space: about 172 GB plus 64GB for swap. Afterward, however, at Grub, selecting Ubuntu causes the boot to hang on an ASUS splash screen. Selecting Windows boots to that desktop normally.

There are reports of 21.04 installation problems on Macs and with Ubuntu Unity. Those who have managed to install this successfully, did you need to do anything special? Is your system dual boot? Did you upgrade from 20 or do a full new install of 21.04? Did you install from a .iso or via the Microsoft store? Are there any other changes I need to make in the BIOS/UEFI?

Thx very much for any help.

I have an Asus mainboard also.

  1. I don’t know why you disabled secure boot and fast boot. Ubuntu is a major Linux distro so it has no problem running with them. I just install Ubuntu with both of them on which is the default setting.

  2. I don’t know why you chose BTRFS when Ubuntu officially supports ZFS. If you want a snapshot-like file system, you’re better with ZFS. Otherwise, you can stick with ext4 or better with F2FS.

  3. I don’t know why you created 64GB of swap (I assume partition). It’s just painfully wrong :sweat_smile: Ubuntu has been using swapfile for as long as I can remember and it is using swapfile by default. By using the swapfile, you better distribute the wearing across the SSD better. However, most likely, you will have to remove even the swapfile afterward in order to speed up your plotting providing that you have enough RAM. Even in a normal system setup, if you have limited RAM, you would use ZRAM instead of swap.

My advice would be… stick with the default setting :sweat_smile:

Thanks for your reply.

Everything I did was because multiple (recent) “guides” recommended it — particularly for dual-boot systems. Including the swap partition. Is your system dual-boot? I wouldn’t have thought to disable secure boot or fast boot on my own. But you’ve convinced me to use a swap file instead of the partition.

I chose BTRFS because some of the people on this forum using Ubuntu and MadMax reported excellent plot times using it, and it was one of the best performing file systems in a direct comparison that was linked here. I’m certainly willing to use XFS or F2FS.

Could you elaborate on your statement about removing the swap file afterward to speed up plotting? Not sure what you mean here.

You don’t have to follow any guides if you want to dual boot Ubuntu with Windows 10. The default Ubuntu installer will detect the EFI partition automatically and will ask whether you want to dual boot with Windows 10 or erase the disk and instal (only) Ubuntu.

My plotting machine is not dual boot but my laptop is. However, it should not relate to how you would set up the swap partition. The booting process depends on the EFI partition which normally doesn’t need any modification from the user as the installer will take care of all the processes. In fact, you can’t choose the wrong EFI partition within the Ubuntu installer :sweat_smile:

The swap partition or swapfile is necessary when you don’t have enough RAM. This prevents your system from crashing when you run out of RAM, that’s why it’s enabled by default. To make it easier to understand, while the swap lets you use your SSD space as your RAM thus made your system slower, ramdisk lets you use your RAM space as you would normally use your SSD space thus made your file operations faster.

Basically, the swap has no place in your carefully calculated plotting rig. I suggested you remove the swap completely because it’s easier to remove it than to mess with the swappiness value (the value that determines how fast your system will start using the swap).

I recommend you to start over and install your system with EXT4 for your system partition to avoid any unnecessarily complicated stuff. You do not need a fast filesystem for your system partition. However, you may need a fast filesystem for your temp partition that you will use for plotting. Then you can remove the swap with this command:

sudo swapoff -v /swapfile

Then sudo nautilus and remove the swap file entry in /etc/fstab file to make your setting above survive reboot. In the fstab file, you need to remove this line:

/swapfile swap swap defaults 0 0

I recommend you start everything with the default setting. Ubuntu installer could be the simplest installer compared to any OS installer on earth including Windows :sweat_smile: Then you can go from there to tweak your system. In fact, it’s not a good idea to disable secure boot and fast boot in the BIOS if you plan to dual boot. In the past, Windows would require secure boot in order to be able to boot into Windows.

1 Like

Thanks much, this is very helpful. It makes sense, although strange that several guides seem to think the quick boot/secure boot changes are necessary.

I didn’t mention this earlier, but the reason I wanted to have a fast file system on the SSD was primarily for the swap space. It would be used only for overflow from the RAMdisk (I’m going to try to plot only in RAM at some point — have 256 GB).

Thanks again for your help.

1 Like

Well ubuntu just isnt as perfect as some would let you believe. Sometimes it has trouble just like windows does, thats why the whole internet is full of troubleshooting guides. Many of them pertaining to Boot issues

I tried installing 21.04 yesterday as well (20.04 was running on that system)
First install failed. Second time it worked but it had weird semicrashes where the screen would turn off and then come back again…but after first restart, system wont even post anymore.
Not even sure how thats possible, but it happened

Wrong forum??? You should do this in Ubuntu forums where you can get more help.


So last night I reinstalled Ubuntu. Exchanged the swap partition for a larger swap file. Was able to use XFS without any difficulty also.

However, this what fixed my boot problem. Apparently it was an NVidia driver issue. (The “nomodeset” fix in this article.)


@Voodoo Maybe this would work for you? Your problem sounds similar to mine.

tnx I have had the feeling that my rather ancient video car is wat has been causing my troubles (also in windows) My is AMD though, but I’ll have a look If I can find something similar.

For now - knock on wood - my boot issue seems to have been resolved after a complete power down and bleed.

Does Live Linux work?