Ubuntu GUI Installation Fails on electron-winstaller

Hi Folks,

I’m using ubuntu desktop 18.04 and am having an issue installing the gui. When I run sh install-gui.sh, it fails on “electron-winstaller” with the below error. It seems wrong that this is trying to use a windows version and a 7z-exe file. However, just removing the package from the package.json leads to other errors.

Note I also saw this person having this same issue on 20 but didn’t see an answer for that question.

Error

Error: EACCES: permission denied, copyfile 'vendor/7z-x64.exe' -> 'vendor/7z.exe'
    at Object.copyFileSync (fj.js:1991:3)
    at Object.<anonymous> (/home/user/chia-blockchain/chia-blockchain-gui/node_modules/electron-winstaller/script/select-7z-arch.js:14:8)
....

Thanks!

I have the same issue …


Hi. I had a node working, until yesterday. It soped syncing un ubuntu. I do not know what is going on… Please help!!