Upgraded to 1.3.0 - DB file still large ( +70GB) and can´t connect to pool ( stuck in pending)

I upgraded my main node to 1.3 ( took 36 hs or less…) but i found some issues:

  1. DB file is at the same size as 1.2.11 ( 73 GB aprox) - I upgraded on another machine and DB is 40GB
  2. cant seem to connect to pool… even when i try to connect, its stays pending ( for a long time)


I opened a report in GitHub also (Upgraded main node to 1.3.0 - DB still to large and cannot join pool[Bug] · Issue #10667 · Chia-Network/chia-blockchain · GitHub)

Can someone help?

Downgrade client to stable version, wait for fix.

is this a known issue?

It’s known buggy, general concensus seems downgrade and wait.


I upgraded to 1.3 from 1.2.11 and ran “chia upgrade db” and everything worked perfect.

You should have two db files after the upgrade. The v1 and the new, v2. The v2 should be a little over 30GB.

Check your config file that it is now pointing to the v2 db. Which the script does by itself.

Restart the farmer. Make sure everything is working. And you can delete the v1 db. Or keep it as backup somewhere.

The upgrade was amazingly seemless for me. And I had plenty of concerns hearing the troubles some people went through.

Good luck! Farm on!


Close the GUI while PENDING (which puts the switching into a failed state when you relaunch), and then switch to self pool but add a fee! (I did 60 mojos to get ahead of any dust storm). This time wait, it should switch to solo. Once your self pooling switch to your regular pool the normal way.

this worked for me.

1 Like

Me ocurrio algo parecido y en una de mis cocechadoras dice que que estoy en SelF Pooling pero space pool me detecta dentro de la misma.

I am on day 3 of upgrading the DB. Ran out of space on my 160G SSD and didn’t have another SSD in stock so cloned to a 2TB HDD. Didn’t realize it was a 5400 RPM? But I digress. The SSD ran through the upgrade fairly quickly, until it ran out of space. Didn’t realize I ever purchased 5400 drives?! The longest portion of this upgrade seems to be in the “4/5 converting coin_store” that has been going over 2 days. Currently on “84480k coins 326.3 coins/s”. Based on what I’m reading here I’m stopping the process and going back to my original SSD, clone to a 7200 RPM drive and see how far I get. I like a challenge. I appreciate the other feedback/notes and will not be optimistic. Prepared to rollback and wait for a stable release. I’ll add this observation, my v2 DB is already 37G, and growing, v my v1 DB at 84G.

Thank you.

Are you running windows? And when you cloned the disk, if running windows did you resize the partition?

Yes and yes. I use Macrium, which has always worked for me.


So might you have a image from the old disk? Then copy that image to the new larger disk (7200 rom) and then do the upgrade again. I used Acronis to make my images, been using it for more than 10 years.

Yes, I can still boot from the original SSD. That was my plan to get off the slower drive. I used to use Acronis. Both good products.

Just go back to your SSD, and run db upgrade across two drives (CLI Commands Reference · Chia-Network/chia-blockchain Wiki · GitHub):

chia db upgrade --input c:\...\blockchain_v1.sqlite --output d:\...\blockchain_v2.sqlite --no-update-config

The read load (c: drive) is about 3x higher than write load (d:), so potentially your d: drive HD will not bottleneck too much.

Also, I would stop chia completely before doing that. It should take around 1-2 hours or so. The process is mostly i/o (drive) bound.

Once the process finishes, move your v1 db out of c: and move there v2. You will also need to modify config.yaml (change v1 to v2 on blockchain db, as you will reuse the same location).

If you skip “–no-update-config” flag, config.yaml will be modified to have d: path for v2 there, and you may not want this.

Although, it is really not the best thing to host your dbs on your OS drive. There is a lot of writing in blockchain db, so you will slowly degrade that drive. Also, OS will have some activities on that drive, what will slow down chia blockchain operations (bad during dust storms).

Lastly, I assume that you are on v1.3.11

Sounds like a good idea. Given I am +/- 20G free I want to migrate before space becomes a real issue. I am only 1.3.0, not 1.3.11. Didn’t see a lot of feedback re: any 3.x being really stable but do like to stay current.

I would update to v1.3.11 before running db upgrade. There were too many bad reports about v1.3.

So far so good


Is that the latest DEV? 1.3.1 is the latest full release, at least according to the Chia.net site.

That is the latest build ontop of the 1.3.1 release

So back in Mar I upgraded my 88G v1 DB to v2. Today I’m back to 88G w/v2? Only getting bigger from here. Searching the channels now.

Here is my db size in 6 months it will grow every day.

So how much space do you have on your C: drive if your a windows install?