Vpn100 m.2 2tb. Only 450mb. (Read/write)

Hi, anyone know how to setup bios/windows 10 to get max speed out of my viper VPN 100 M2. 2tb. ?

I currently get like 450(read/write)
But the box state that it could be much higher ? :cold_sweat:

Did you connect it using a PCI-E Adapter or directly to your mainboard? Speed looks like SATA speed, not normal for a PCI-E connection. Maybe a problem with a PCI slot that does not give x4/v3 speed?

1 Like

Check the bios settings for, “pcie version” or whatever other setting related to the pcie config, might be something going on there.
Also, depending on the mainboard/cpu there could be an issue where the m.2 slot only runs at certain speed if you also connect other lanes.
for example X570 chipset uses pcie 4 lanes to connect to cpu, so everything that is connected through the chipset shares those 4 lanes.

1 Like

Connected into the board… But my Windows is running from an 240 Kingston SSD, i have not installed anything into the viper m.2, i have just connected to the board … It that ok ?

You are testing C drive which is 240GB, you should change the drive letter to correct NVME drive.


I have the x570 pro wifi … But when you say through pcie 4 lanes… do you mean through here…:

How exactly can i exactly connect the cpu to the 4. Lan ??? I’m a bit lost, sorry :neutral_face:

You may also want to check BIOS → Advanced → Onboard Devices Configuration.

According to manual, M2.2 supports both PCIE 4.0 x 4 and SATA mode, you may need to toggle mode in BIOS to PCIE 4.0 x 4 mode.

1 Like

cr33d0 just told u - the issue is u r testing C-Drive - not ur nvme. U are OK, don’t worry - be happy :slight_smile:

1 Like

Yes i can see that you were correct, but what about when I’m trying to plot… I am not even close to the max speed, I’m still around the 300 mb/s … Jumping high and low like crazy…

Please see below:

Yes it is connected directly into this place

Again, don’t worry. Max nvme speeds are rarely seen. Plotting is a VERY mixed workload. The nvme only does what’s necessary. It does NOT just show max speed in task mgr every time an access is asked of it. Everything looks normal to me after watching ~1000 plots.

But I’m not getting the same speeds when plotting… Please see below :

Did you use madMax plotter? What settings do you use? At which phase of plotting, the speed is fluctuating? Irrespective of that, how long is time duration for 1 plot to finish (phase 1-4)?

I use madmax, correct. It takes about 1 hour for every plot. With:

5950x cpu :cold_sweat:
64 gb ram (2x32 gb)
X570 pro wifi
2 x 2tb. Nvme m.2

Setting :

.\chia_plot -n -1 -r 16 -u 256 -t “F:” -2 “G:” -d “J:” -p “ac6c670c5c2443362049397756e748c5d850016a5b46471ab6921c30738a3772c540fc24296533aa2f60b235121939f9” -f “9034e94f0bf765685e7bab2c133be651c99cedd933059460b2056d2224de70a1019fce457eee28c150f88901a8a6135a”

Nah don’t worry too much, I guess it is the limitation of the NVME sustained read/write speeds. See below my screenshot using 980Pro 1TB during Phase 1.

1 Like

F and G is my 2 nvmes m.2

Yes i see, but i was hoping to get like 30 min. Pr. Plot

But i guess I need 128 gb ram for that… I will receive my 128 gb. Ram in 2 days.

So the question is if it’s plugged and play… Or should I raid my ram or something else …?

For Windows, using ImDisk is recommended to create a 110GB ramdisk to use as temp2.

How to do that: google :slight_smile:

1 Like

I get it, for such setup you should expect more performance. Even for me using 13 threads from R7 3700X, 32GBRAM, just took 40-41 mins.
There are some variables.
They said with Linux you can get faster plotting.

1 Like

Okay, i will Google it :blush: but should i set my temp 1 as " nvmes m.2 2tb" and the temp 2 as " 128 gm ram" ramdisk ? Right ? :blush: