WARNING No keys present in Linux -- how to fix?

Unfortunately, I created 10 plots using the Linux GUI before figuring out how to check the debug.log. Newbie mistake! This warning appears in the debug.log:

WARNING No keys preset. Create keys with the UI or the ‘chia keys’ program

The only issue I have is with Farming.

  • I am synced.
  • Port 8444 is open.
  • Others are linking fine.
  • Plots statuses are all Farming
  • Challenges about every 10 seconds. 0/10

But no plots ever pass a filter. (I’ve checked the 5 visible many, many times and promise to restart with log_level INFO, but that’s not gonna help without keys!)

As a newbie I am guessing there is a mismatch between my plotting key and farming key, but what do I know? I can get my Private Key from the GUI’s Keys page by clicking the View (eyeball) icon. Note: I first tried to install Chia on Ubuntu using the Terminal windows and chia.net’s steps. That failed. Then I “successfully” installed with the GUI installer.

Where/How do I change the Private Key for Farming, if that is the solution? Thank you for helping a newbie!

Problem solved, I hope! Wiped the drive. Reinstalled Ubuntu 20.04. Reinstalled Chia with the Ubuntu GUI for 1.1.4 (just missed the release of 1.1.5 :slightly_frowning_face:).

I recreated the private key with my 24 words and selected the plot folder on its external hard drive. Now the plots are syncing. For 26 plots on an old computer syncing takes a loooong time, maybe 14 hours. But it is syncing.

Thanks to everyone who read this post!

Syncing has nothing to do with your number of plots. Syncing is the process of downloading the blockchain from other peers. It’s currently at ~2GB so it takes a little while.

1 Like

Thanks, @zogstrip - that’s good to know. I see that the sync process also is not dependent on download speed. Otherwise it would only take minutes rather than many hours.

By the way, the reformat, reinstall, and synchronization worked beautifully. I now have plots passing filters occasionally as they should.

1 Like

I’m still not sure what exactly happens during the sync phase but I can see it using a heck of a lot of CPU. My theory, and I haven’t investigated this at all, is that it needs to do calculations to verify that there’s no corruptions along the way.

1 Like