What are the sleep settings to disable in Windows when plotting Chia?

Is there a complete list of sleep settings to disable in Windows 10 to prevent any interruptions with Chia plotting?

AFAIK its:
Power Options > Click on the plan you are currently using (Ex: Balance) > Change plan settings
-Put the computer to sleep > Set to “NEVER”

I am not sure if the turn off display is fine to leave as is?

Then click “Change advance power power settings”
Under USB > USB Selective Setting > Set to Never

(This I think is important if you have Hard drives that are connected via USB such as:
USB External Hard Disk Drives

Any SATA Controller that makes your Hard Disk drive when connected to it, behave as a Removable USB like AsMedia ASM1061 (I actually experienced this feature on an old Intel X79 Motherboard, it had this controller).

And on the last note, it is important to make sure that all drives connected to your system have indexing turned off (This PC > Right click on drive > Under general tab, turn off “Allow Windows to index…”)