Why does it take so long for "full node status" to update when starting?

Every time I start the Chia application, it takes quite long for the Full node status to change from “Not synced” to “Syncing”. I don’t have a good idea of what is happening in the time that it’s seemingly doing “nothing”. What is happening and why does it take so long?

Bonus question: it takes quite a while to sync as well when restarting, is there that much data being transferred?

Happy to be corrected if I’m wrong about this, but I think it’s because of the peer-to-peer nature, it can take a while to find and connect to enough peers to get a full picture of the network. Syncing is pretty slow tho. My solution: don’t ever stop the application :slight_smile:

1 Like

There’s some good info in this Reddit thread about this: https://www.reddit.com/r/chia/comments/mtu7k4/i_am_having_problems_syncing_heres_some_steps/

The reason why many are having issues, is because too many are disabling uPnP and making their nodes unreachable to the general network. If you have not disabled uPnP, is your router setup to allow it? If not, setup a rule on your router to forward port 8444 to your Chia nodes local IP address.

Doing this will make more nodes discoverable and able to send data so everyone can sync. If you are running multiple nodes on your local network, only disable uPnP on ONE of the machines, leave another open so it can help out and strengthen the network and onboard new users.

In the meantime, until people change, there are “introducers” you can add that will attempt to give you a list of peers, until more people open port 8444, many of them will be unreachable allowing this issue to continue and compound more and more each day as thousands come online.


These introducers were active at the time of this message, they may not be in the future, so please don’t depend on them to help you try and find nodes, FORWARD PORT 8444 ON YOUR ROUTER, or enable uPnP so the program can add a rule for itself, more need to do this for everyone to succeed.

  • Make sure port 8444 is open: https://www.yougetsignal.com/tools/open-ports/

  • Make sure UPNP is disabled on all but one machine: chia configure -upnp false (to disable and true to enable)

  • (Windows) In C:\Users\NAME\.chia\mainnet\config\config.yaml change log_level: WARNING to log_level: INFO and restart chia. (You can restart the GUI and not hurt CLI plots, but GUI plots will stop)

  • Your log files are in your log folder. Your blockchain (the huge file you had to download to sync) is stored in the db folder, it can be backed up.

  • When you update Chia make sure you shut down chia and reboot first. Then install the update and let it sync.


Aha! Thanks that makes sense, unfortunately as my rig is in the office I can’t control ports, I would love to be a more productive contributor to the network.

Additionally, upnp is pretty evil so it’s blocked by many routers.

Just for reference, I went from ~5-15 minutes to sync to pretty much INSTANT sync after I forwarded port 8444 to my farming machine. It made a huge difference.


I’m keeping a BK of the blockchain DB every night just in case. Eventually it will be huge (like Bitcoin) and a pain to download.

1 Like

Yeah that’s not a bad idea. I tried to get an old laptop up and running and took a backup of the database folder from my Windows machine to the Linux machine. That was a no-go, not sure why (I use the same mnenomic for both machines). Could be an incompatibility between Windows and Linux of course.

1 Like

Haven’t tried that, only between Windows machines.

1 Like