1.3.3 keys to success upgrade now!

iv successfully upgraded to 1.3.3!

fixed so many issues I was having.
I was fed up
I encourage everyone to quickly do the same.

ditch that old tired wallet db and jump on that 1.3.3!

re sync only took 3 days over gigabit copper.

my gui has never ran smoother.

just feel like that needed to be said.



Good luck, all my boxes are on 1.3.3 (farmer/harvesters)

From what version?

Please list a sample or two.
Or was it syncing and a smooth GUI that were the fixes to which you alluded?

I am asking, because I am running 1.2.11, and have no serious issues. So I am hesitant to upgrade. So I am curious which version you were having issues with, and what those issues were.

You can always just copy both folders .chia .chia_keys for super backup…

1 Like

I was on 1.2.9 and it started with some mild sync issues. randomly id find the machine had lost sync and would need a reboot to get it to catch up… or even recover from a backup to get the sync moving properly… later realized from logs and pools that I had lost sync entrely for a week.
sick of it
so I went for the 1.3.1 than everything went to more crap. my plots forgot they where nft and started solo plotting again. my nfts all disappeared. logs said everything was fine… than my xch numbers started to not add up correctly… so I was like f… this all took place over the course of a few weeks.

so I was recently instructed to try deleting my wallet db… and at the same time I went for 1.3.3

my guess is 1.3.+ doesn’t play nicely with the old wallet db… Wich is unfortunate because people for whatever reason are attached to their old one. and are carrying it with them… this is a problem…

simply upgrade to latest version. delete ur wallet db… reboot. and finally stop worying about syncing issues.

ben running like a top for a week now. 0 issues. with my wallet windows 11. and my vm windows 10 farmer and harvesters

1.3.3 I think is a real milestone if people can learn to let go of their wallet db.

resynced in a few days. cake

1 Like

So you deleted both your wallet db and your blockchain db, and you let 1.3.3 recreate both of them from scratch?

no. I just deleted the wallet.db. and that took 3 days. it fixed a mess of issues seemingly unrelated to the wallet db… but nevertheless.

there are improvements to more than just my bug fixes. it really runs like butter now. faster. more responsive.

but I mean… using a old db… how fast is the gui supposed to be ya know…

put some new sails on that ship


1 Like

And did you have it compress the dbs?
Or are you using the dbs in their uncompressed state (the way 1.2.11 used them)?

I am asking these questions so that when I take the plunge to 1.3.3, I make no missteps.
What you did worked. So I will probably follow your lead. But I might not delete my wallet db, because I have no problems with it. But if someone gives me a good reason to delete and re-create my wallet db, I am all ears.

no for surer no worries. I get it.

iv only used the wallet db as it was given. no altering anything… except for when I deleted it. when it was in its v1 form. all the data it holds it will learn again. in a better way.

I believe now it is compressed. it did it all automatically. once gui saw it was missing… 1.3.3 just started to resync it. not even a hiccup…

the wallet db isn’t what holds your chia ya know? your 24 key does.

there’s nothing I don’t think u can delete client side that will affect that fact.
don’t quote me on that tho… lol

1 Like

more newer more better,

its a major upgrade…
affects how the whole thing operates
they should just put in the notes that its wise to just delete the old wallet.db file.

the old db doesn’t play nice with anything newer than 1.3 that I know for sure

1 Like

In order to have access to your wallet, you need your 24 word mnemonic.
But I thought that your XCH is dependent upon your wallet being synced?

For example, add your 24 word mnemonic to some other fully synced computer, and I suspect that you will not see your XCH, because your wallet db is not there.

And your wallet gets synced based on your blockchain db being synced (I believe).

So it is my understanding that you have to be synced to have access to your XCH. Is that right?
And if that is right, then it means that your wallet does hold your Chia, albeit encrypted where your 24 word mnemonic is the key.

And you can lose your wallet or anyone can make a copy of your wallet and it will not matter, as long as you never lose your 24 word mnemonic to bring it all back. That is my understanding.

By the way, if version 1.3.3 organizes your wallet more efficiently, then even though I have no issues with my wallet, I will make a copy and delete the one that Chia uses, to trigger its re-creation. And this should not interfere with farming, so there is no downtime.

For example, add your 24 word mnemonic to some other fully synced computer, and I suspect that you will not see your XCH, because your wallet db is not there.

your xch do show up there. once the wallet finishes syncing. I assure you… its how I run my wallet on my home gaming pc. and only access it when I need it…

my farmer holds the same wallet…

both have their own generated db

ur wallet.db and your actual wallet… don’t really have anything to do with each other. sure it has to be synced in order to give you correct number of chia u have… but other than that… ur wallets not tied to it like that.

iv nuked everything and started from scratch a couple of times… iv changed my virtual machines at least 2 times.

with only my 24 to fall back on…

farmer always recognizes everything from ur 24 key. the data ur syncing with… everyone has available. but the data you seek can only be unlocked with the 24…

When I upgraded from 1.3.0 to 1.3.2 a couple of weeks ago, my wallet was missing some of my coins and a lot of my payouts from my pool. I found someone else had the same issue a few weeks earlier and they deleted their wallet db and let CHIA re-create it. I did that and after a few hours of syncing, everything was back to normal.

Tip for those having this same issue: Don’t delete the files in wallet/db that are named “wallet_peers.” I had originally deleted all files in there (I made backups, of course) and then after I started CHIA, the Wallets screen kept switching every 1/2 second between “syncing” and “offline” and wouldn’t ever actually sync. Once I put those 2 “wallet_peers” files back in and restarted CHIA, it was able to sync in about an hour. So, you really only need to delete the files that start with “blockchain_wallet.” You can probably also delete any 0KB files in there. (I did, at any rate)

1 Like

[quote=“jonesjr, post:7, topic:16296”]
just deleted the wallet.db. and that took 3 days.
[/quote] sic: to sync after

So, you have been dusting?

what even is dusting:?

1 Like

Wallet db is 15 MB, so that is one of the records on this forum. Looks like super speedy H/W.

I sent myself thousands of coins and it made the wallet take days to sync

1 Like

I don’t get it.
What’s the point of dusting? And how does one do it? Maybe there’s lots of people dusting that don’t know it.

For me I was mostly just testing how it worked. If your wallet took days to sync maybe someone attacked you with dust coins