After node restart, remote harvester gives error "harvester_server Cannot connect to host" (solved)

Any time I need to restart my full_note, my remote harvester loses connection (expected) but then it never reconnects. On the harvester machine, I’ve tried both harvester -r, as well as stop all and then harvester -r i.e.

chia stop -d all
chia start harvester -r

The only solution that works is a reboot of my harvester machine. Is there no better solution? It’s hardly scalable. This is the message from the log:

2021-12-03T10:13:39.855 harvester harvester               : INFO     Reconnecting to peer {'host': '', 'port': 8447}
2021-12-03T10:13:39.862 harvester harvester_server        : INFO     Cannot connect to host ssl:<ssl.SSLContext object at 0x7f759eeff940> [Connect call failed ('', 8447)]

And from the harvester you can ping ok?

Yes. I just restarted the node to double-check. You got me thinking about what else could be in play. I’m running UFW and port 8447 was set LIMIT IN. I changed to ALLOW IN and boom, the harvester reconnected immediately. Since 8447 isn’t open on my router, a LIMIT rule isn’t needed (I think/hope!).

In my router I have UPNP off and port forward (8444 to my main machine farmer)

Yes, same here. It seems to be the most reliable setup. 8444 is then also opened with LIMIT IN in UFW on the full node. I don’t see any 8444 connections being blocked in UFW log. Might not be strictly needed though. I’m unclear if there is anything that could be brute forced?