Chia plots are missing keys after setting up a new farmer


since Chia db was eating up a lot of space on my personal PC i’ve decided to purposely build a farming PC. Everything went good until opening Chia GUI and seeing that none of my plots from any of my harvesters are working due to missing keys…

I already deleted Chia from my personal PC, however I have my ca folder backed up. I did chia init on farmer and both harvesters. I have my mnemonic imported on my farmer and my node is fully synced (Used database snapshot for that). I don’t know what is relevant to post with this since there are no errors in logs on any machine other than that warning with keys that are not on farmers pk list.

I would appreciate if you tell me what you need to see to help and post it as a response. I tried googling but never found any issue similar to mine (People mostly lost their ca/mnemonic, both of which i have).

I had the very same issue.
copy over the ca folder from your farmer node to harvester if they are separate.
run chia init -c /path to ca on the harvester commandline

on harvester and farmer run chia keys add on the commandline.
after that put your mnemonic

if you only have a farmer, do the last step on the farmer. that solved it for me

Did you add your plot directories to the config.yaml file?