Chia Plotting madmax

Hey everyone. So I have I’m using MADmax 5o plot, and I have a nvme, PCIe card, and turns out, I don’t have enough CPU for it :rofl: (I have a 3570k in on machine, and a 3770 in another). What are my current options? So far, running parallel MADmax instances to a single NVME has been helping (same with doing so with 1/2 my threads to one ssd, and the other 1/2 threads to another, separate one).

I think a lot of people are confusing older guides with newer ones.

Older guides optimize plotting using the official chia plotter and plotting in parallel to create more plots. This makes better use of the system’s untapped resources to create more throughput.

Newer guides recommend madmax to optimize plotting by making plotting a multi-threaded process and maximising the usage of available resources (CPU cores, PCIe bandwidth) more efficiently to create plots one at a time but more quickly.

But people who read the guides seem to confuse and combine the two approaches. They don’t realise that with madmax you typically don’t plot in parallel.

Madmax is used to make plots one at a time, and it will automatically utilize the resources available to produce a plot as fast as possible without having to plot in parallel.

So, with your system, using madmax, give it all the threads, and let-her-rip. It will make plots as fast as your system will allow without having to mess around with staggered plotting and parallel plotting.

1 Like

Yes, I’ve used both. Im trying to maximize MADmax, but with my current setup, in experience, I can only go so fast on my 3570k, and 3370. The 3370 is obviously faster with 8 threads, however by experimentation, rather than plotting a single plot with as much resources I possibly have, splitting in half my resources to two different drives, or the same drive if it is capable, is for some reason going faster. Now I’m just trying to figure out what I need to do to get as fast as possible with my available resources. I can’t explain why, I’m not sure if it’s just more efficient usage, but parallel plotting two different instances on mad max, in my situation, with my current storage drive setup, it’s for some reason just faster.

That is a little strange.

My guess is there might be something wrong with your madmax command.

Can you write out the two different commands you’re using for comparison?

It could also be that madmax doesn’t play well with old hardware, but I’m not sure about that.

Could it be that the number of CPU cores is so low, that there is little difference between plotting with madmax and the official chia plotter? :thinking:

I don’t have the full command currently, but I know what I did. Btw, I’m using the gui version. I’ve so far only tested the nvme on my 3570k pc (which I tested crystaldiskmaked, running perfectly). This was on my 4c4t 3570k (not overclocked yet) I ran 4 threads, 2 on the thread multiplayer (not sure what this does, haven’t got much info, but it is a bit faster) 128 buckets on first part, then 64 on the rest (I know it probably shouldn’t be that low, and I heard everyone was just leaving them as 256 by default, or 256 and 128 on the second part, and that was their fastest. But again, through testing this is the fastest I’ve gotten), I have no room just, my only plot is to the nvme. And the final disc is two a hard drive, which actually gets transferred at 188 MBps average. I do not wait for the transfer to complete before starting a new one, because I have a one terabyte nvme. Although this time is not based on also copying the hard drive, this is the first plot I did on it taking 3 hours.

A bit weird, just a super random test, but I’m currently running 4 (yes 4) instances of mad max on my 3770 4c8t, all using two threads, 128 and 64 buckets again, 2x through multiplier again, basically same settings just two threads for each, and these are all applying to the same mvme. It has not finished yet, but I’ll let you know specs once it’s done. But the first table was faster, and my nvme never dropped under 1.5GB/s in task manager. However 2nd table was a different story, maybe averaging 400/500MB/s for all 4 instances (started same time) together.

There’s a GUI for madmax? :face_with_raised_eyebrow:

(Edited, reread maybe)

I’m yeah. It has the commands (like “-k” for where I input the threads) I don’t have where I downloaded it from exactly, but I have the whole file) and it does give me the full like command. I just don’t have it right now. I’m not home

Nope, you’re right. There’s now a GUI for it. Its new. :thinking:

Okay, cool. The plots test legit, so I know it all worked and everything. And it was definitely faster LOL

./chia_ploter/chia_plot.exe -f key -n 50 -r 2 -K 2 -u 128 -v 64 -t F:\ -d E:\HDD_B\HDB_PLOTS\

F:\ IS my nvme, E:\ is my HDD…

Yeah I don’t know… if its faster that way, then who am I to argue.

The oldest hardware I’ve tried plotting with is a 6600k. Results can be seen here:

In that experiment the SSD was the bottleneck and the CPU wasn’t being utilized all that much because of the restrictions caused by the SSD. When I put an NVME drive in it the CPU ran full-throttle and I was getting 2 hour plots with madmax,

If your CPU is maxed out under madmax, then your only option really is to upgrade.

Its really just a game of finding out where the bottleneck in the system is, and making upgrades to remove the bottleneck for better throughput.

Your 3570k system has 4 cores (4 threads) but you’re using -r 2 (2 threads). Have you tried giving it all four cores/threads with -r 4.

With your 3770 system, 4 cores/8 threads, have you tried using -r 8 (8 threads)

Okay, interesting. The fastest I can get is doing two parallels, splitting my 4 core 8 thread in half for each, to Samsung 860 pros 500 gb, and when I did a per plot calculation, it came out to be just over 3 hours each plot. That’s the fastest I’ve gotten so far, well besides my nvme taking 3 hours with 4c4t thread full system resources

Maybe this is just in the example, but you are missing either -c or -p in this command

What do those refer to? I was able to get on my TeamViewer for my computer, and I basically just copied it’s log file readout, so that’s what it told me it was doing basically.

  • -r - The number of threads to use (in this case you used 2).
  • -c - The pool contract key, to make a poolable NFT plot for a pool.
  • -p - Pool key, used to make an non-poolable OG plot.

In your example, it had neither the -c option or the -p option which looks a little odd (because the command really should have one of them).

Maybe thats what the -f key is… thats new. Nope. Thats the farmer key lol.

, I did erase one of them and put “key” instead, honestly I’m not sure which one’s supposed to be private or public. Lol. Although I only erased one key I think

Anyway, it looks like with the options you’re using you’re only using 2 threads.

That might explain why its running slow, and why you’re able to run two plots in parallel and it being quicker.

Try adding more threads and see if there is an improvement.

I have no idea what the -K thread muliplier is for…

This is on my current plotting task, on my 4x8t 3770 with 4 instances running. Won’t be finished for at least another 2 hrs maybe. I’ll let you know results when there done, but increasing threads past (in total) what my CPU has? My CPU is at 100% utilization right now, all the time, my nvme, even with 4 instances is only about 25%.

Same settings, but 4 threads, it took 3 hours on my other computer. Same buckets, same everything. But that was 1 single instance with 1 temp (nvme) so that’s the only definitive result I have so far