Chia plotting on Ubuntu 20.04 LTS

I follow the exact steps for ubuntu 20.04 LTS installation from here: INSTALL · Chia-Network/chia-blockchain Wiki · GitHub

But, when I get to this step:

Then the following error appears:

could not lock config file /chia-blockchain/.git/modules/chia-blockchain-gui/config: Permission denied
fatal: could not set 'core.worktree' to '../../../chia-blockchain-gui'

What I miss here ?
Thank you!

Did you checkout the code as root/sudo, or move the checked out code using sudo, or do any other step as root/sudo? If unsure, look at the output of:

ls -l /chia-blockchain/.git/modules/chia-blockchain-gui/

If any of that shows as being owned by root (3rd column), then run:

sudo chown -R username:groupname /chia-blockchain

Where username is your username, and groupname is typically also your username if you’re using e.g. the user created during the install process, e.g. my username is chia so it would look like:

sudo chown -R chia:chia /chia-blockchain

1 Like

Hey @aschen , thank you for your quick reply!

That’s true. Everything was owned by root!
I run sudo chown -R username:groupname /chia-blockchain, and now they are owned by my username.

Now I run again sh and seems that everything’s good.


Now I think I have another err.
When I want to npm run electron & I can’t.

The reason is because I want to do plotting on a dedicated server that I buy from a hosting company, and I have just console access to it.

There is any other way to do this ?

You don’t need to use the GUI to plot, you can just run:

chia plots create

However, I would recommend using a plotting manager especially if you want it to be unattended (e.g. plotman, swar, something else, I use plotman but haven’t tried swar so can’t recommend one or the other).

1 Like

You’re right again. I heard about plotman. For sure I’ll use it too !
Thanks man