Chia transaction not showing up in GUI

To experiment how it works, I created new mnemomic keys on a computer totally disconnected from the internet. I transferred 0.00005 XCH to the corresponding receive address. Next, I imported the private key in the chia GUI of a computer that is connected to the internet. When I search on for the receive address that received the 0.00005 XCH it shows the correct amount on that website.

However, when I click this private key with public fingerprint on the keys tab in the gui and then click wallets, the total balance is 0 XCH instead of 0.00005 XCH. Why?

Your new wallet is probably not synced. On the Wallets tab in the GUI, what does the “Status” column say?

Well, I added this new wallet as a second key to an “existing” GUI that was already synced because it has my primary wallet I use to create plots and to farm. So it says Synced. When Is witch to the other wallet (I use to farm) it does show the correct balance for that one.

There are three things that need to be synced in your setup: your full node, wallet #1, and wallet #2. It sounds like your full node and wallet #1 are both synced, but wallet #2 isn’t. So if I’m correct, if you switch back to wallet #2, you’ll see that it is still syncing.

PS - Don’t worry, you’ll still be farming if one or both of your wallets are syncing. You only need your full node to be synced in order to farm.

If I switch to the second wallet it still says synced and total balance / spendable balance as 0 XCH

Then there is something else which is weird. In the beginning, in the “Manage Your Farming Rewards Target Addresses” I had the same address as my primary address I use to farm. Then after I won one block I made a cold storage address and transferred that amount to that address. Then I changed the Farming Reward Target Address to this cold address.

Now the weird thing: In the Farm tab the Total Chia Farmed is still 2. However, when I look to my cold storage address on chiaexplorer website, there is a second incoming transaction of 1.75 XCH and 0.25 XCH, so the balance on my cold address is now 4 XCH. How?

Sounds like you won a second block. Congrats! The Farm tab in the GUI wouldn’t know this because it’s tied to your original private key (I think, though I’m not 100% sure). You can find out when you win more XCH by either monitoring your logs or looking up your cold wallet address, which you’ve done.

As for your other problem, I’m not sure what’s going on. Maybe double check that your seed phrase from the wallet with 0 XCH is accurate and make sure your GUI wallet address matches the one on chia explorer? Everything’s synced up, so there must be some other discrepancy.

Thanks Yeah :smiley:
Just for fun, I want to find out which plot files won my blocks. I found the keys with the corresponding height but I wasn’t able to find the corresponding plot file.

Someone else was recently asking about how to find which plot won. I don’t think there’s an easy way to learn this. The good news is a plot can win many times so there’s no need to delete it.

True, but I wanted to know just for fun.

I’m confident it matches. I have no added the same key (with the 0.000005 XCH) to another old laptop and that one is now syncing. Once it is synced we will see what it shows.

1 Like

Yes please let us know.

Initially I added the keys of this address with 0.000005 XCH to a chia client already synced. As mentioned earlier, when I click on that key and then go to the wallet the balance says 0 XCH. When I copy the receive address on that “page” in the GUI and paste it in the seach field of I get the correct balance of 0.00005 XCH on the website. My old laptop is still syncing and it takes forever… (maybe another 24 hours)

This morning it still wasn’t synced. I added the address with the tiny chia amount to another pc already synced. It says synced and the balance says 0 XCH. I transferred a tiny bit of XCH to that address and it shows up in, but still not in the GUI. When I then try to transfer some XCH (despite it saying 0 XCH). I get a message: “Wallet needs to be fully synced before sending transactions”. This wallet was added to the GUI 2 days ago and it has been online & synced all the time for the past 2 days.

I have no idea whatsoever what is happening. Can someone else maybe try to create another wallet, send a mojo and see what happens when he/she adds that wallet to his/her GUI?

The wallet currently doesn’t manage very well having multiple keys. Personally I am creating a different user account for each key in my computer. Each user has its own wallet process started with “chia start wallet-only” and I manage them from the command line. It is easier in Linux but should be possible also in Windows. That way you have one wallet process to manage each key, and all the wallets share a single full node.

It is cumbersome to keep it running between computer restarts, and not very convenient to use. Also hibernating the computer tends to kill the wallets sometimes anyway. I hope it is only a temporary arrangement before the wallet code is improved.

Can you explain me how to do it in Ubuntu? I run Ubuntu. Is it possible there without logging off / on and interrupt plotting? Can you run the same process / daemon multiple times under different users?

This is how I do it in Ubuntu.

Say we want to create the user “bram” to host one wallet, or as many users as you want.

First create as a privileged user a common Chia “installation” accesible to all users in /usr/local/share/chia-blockchain. That is to make easier future upgrades of the codebase. Usual install instructions for that.

Create a runnable script /usr/local/bin/ with this contents:

cd /usr/local/share/chia-blockchain
. ./activate
chia start wallet-only

Make it accesible and runnable to all users

chmod 755 /usr/local/bin/

With this script any user can launch its own daemon and wallet process, but there is a problem, with the default configuration every wallet will have the same ports assigned so they will fail to start

So to configure each user’s wallet, you have to log in as that user and configure this way:

su - bram
cd /usr/local/share/chia-blockchain
. ./activate
chia init

This creates the base configuration in ~/.chia/mainnet/config/config.yaml

Now copy the CA files from full node to ~/.chia/mainnet/config/ssl as if you were configuring a remote harvester, for the wallet to be able to communicate securely with the node

Edit ~/.chia/mainnet/config/config.yaml and make changes to the “wallet” section at the end of the file:

  port: 8452
  rpc_port: 9260

The fields “port” and “rpc_port” have to be unique to each wallet and unused by other wallets or applications. I simply increase them by one unit for each wallet (8451 and 9259, 8452 and 9260, etc)

Now you can start the wallet as bram user with /usr/local/bin/, import your key with chia keys add and manage it with chia wallet command

Repeating the process with other users you can create as many wallets as you want, the only requirement is that the wallet ports need to be different for each user, started and managed independently for each user, etc.

That still is a bit complicated for me. I am not that experienced with Linux yet. As a test I removed the main key from one of my local harvesters so now I only have the “tiny wallet key”. The GUI said “syncing #1/#2” with #1 99+% of #2. Now it stopped and it says “Not Synced”…

Edit: 30 minutes later it is synced again. This is the situation:

  • Running Ubuntu 20.04 with the GUI 1.1.6
  • There is one private key in the GUI and no other keys
  • I removed the plot dir’s from the GUI because they are made with a different key
  • The status says Connected and Synced
  • The balance int he GUI is 0 XCH
  • When I copy the Receive Address from the Wallets tab and paste it into the search field on there is a tiny balance that is shown there. It matches the amount I sent to that address.

Edit 2:
I have removed the “tiny wallet key” and again added my main plot key. This wallet has some tiny balance as well. Immediately upon adding the wallet was Synced and Connected and the correct balance is shown under the Wallets tab.

Finally an old laptop with fresh win 10 install and fresh client - synced & connected. Still the same. 0 XCH in the Wallets tab. some mojo according to

my wallet it show incoming 1.73999999999 and 0.000199999998 and 0.00013999999988
however, all this balance is not on my wallet balance anyone face this issue before?