Connection closed IP-Address Node Id

Hello together,

today I set up a new machine and it should run the harvester only. I copied over the ca-folder with the 4 files and did the chia init with -c ca. Everythings seems correct. Then I edited the config.yaml and added the address and the mnt-folders. On the harvester machine everything seems fine and the eligible plots are found.

But when I check on the farmer I’m getting the error message that the connection is closed.

Do I have to open ports on the farmer for the connection to be established? I have tried the following:

iptables -I INPUT -s -p tcp --dport 8447 -j ACCEPT
iptables -I INPUT -s -p tcp --dport 8448 -j ACCEPT

But it is still not working. Can anyone provide here the solution?

This is the document to follow - Farming on many machines · Chia-Network/chia-blockchain Wiki · GitHub

Based on what you wrote, I assume that your harvester is at …175.15. The logs you provided show that your farmer is seeing your harvester (…15) connecting over port 8448 what is not the correct port, thus those disconnections. Your harvester needs to talk to your famer over port 8447. That section above from Chia’s document shows config.yaml harvester setup (specifying that port).

If your ipTables are restrictive (on the farmer), then you do need to open that port for your harvester. From your harvester, you can run telnet FARME_IP 8447 to test whether that port is reachable. I don’t think that you need to open any port on your harvester, though.

I’m still getting the same error messages. The guides are written in an older chia version. Having 1.7 right now and the config.yaml looks completely different.

Is this your first harvester box?

Do you have other harvester boxes that are working properly?

How config.yaml looks like has not much to do with how the protocol works. I doubt that harvester protocol was changed, as you are the only person having problem with it (at least on this forum).

Try to identify the harvester / peer section, and just ignore everything else in that section (other than host and port). If in doubt, post your relevant config.yaml section.

You can also try to test farmer from your harvester openssl s_client -connect FARMER_IP:8447. This should dump chia related SSL info. This would make sure that your init worked properly.

It is the first harvester-only machine.

For some reason the error message keeps occuring when I use

cat ~/.chia/mainnet/log/debug.log | grep

but when I use chia farm summary it is showing the remote plots and the pool is also showing them. So it should be farming now.


This is from my config.yaml file, which the machine is a harvester and I’m running 1.7.0 on it.

crt: config/ssl/ca/chia_ca.crt
key: config/ssl/ca/chia_ca.key
port: 8447
logging: *id001

1 Like

By the way, how do you start your harvester? Do you start the full node, or just harvester?

I’m just starting the harvester with:
chia start harvester -r


it looks like port on your harvester pc is closed.

OK then how to open it?

Since you in windows go check some docs windows open port - Google Search

Which port is closed?