Copied a working db file to a node causing errors on that node

I’m running a full node on my PI4, worked flawlessly till the SD card died three weeks ago. Blockchain db sits on a usb ssd drive.

So I just got a new card, reinstalled ubuntu and most recent chia client. Because I had no time to take care of my Pi immediately after the card died and I don’t wanted to wait till the missing 3 weeks of sync are back on my Pi, I copied the db file from my plotting PC over to the ssd on my Pi

In the past i did this several times, worked without any issue, that’s why I didn’t even thought about keeping a backup of the db on my PI. Unfortunately this time, if I start the farmer on my Pi with the copied db, I get a bunch of error messages that end with:

sqlite3.DatabaseError: database disk image is malformed

Google told me, the blockchain database is probably damaged. Which is odd, because on my plotting PC the node works just fine.

Has something changed in the client, so that it is not possible to copy a db file? Or do I now have to copy additional files along with the db?

1 Like

I cant be sure but ive not seen anyone discussing it.

The only things thst pop into my mind are.

  1. The database got corrupted in transfer possibly.
  2. The ssd on pi is having issues.
  3. You copied a v1 db and it wants v2.
  4. The latest release ( i believe 1.6.1 ) does install the files in a different location, and uninstallung the old software before installing the new is supposed to be done to stop problems ( or so ive read ).

Hope this helps, good luck.


@Auriga did you shutdown the node before taking the back copy?


Yes, I did shut down both nodes before doing the copy. I also took the V2 db, I deleted the V1 month ago anyway. I’m also sure I took the right one.

So, yes that’s what I also thought: Probably some Issue with the ssd. Or the db in my plotting PC is indeed broken but the Chia client just doesn’t know it jet :wink:

At the moment I let the Pi do a resync from scratch, which is absolutely pain.

1 Like